Macbook internet connection failed only at home

Discussion in 'Mac Basics and Help' started by waytoofunny, Oct 17, 2008.

  1. waytoofunny macrumors newbie

    Oct 17, 2008
    Hi all - I'm new and I am a VERY proud owner of the new Macbook (not pro) that was released this week. I am in love already but I have a problem. I was able to connect to the internet at my school (I'm a teacher) with no asked for the WEP passphrase and away I went. I was at a cousins house tonight and I was also able to connect there...but only after renewing the DHCP lease. I have not been able to connect ever at home. I have a PC laptop with no prob...
    It is a linksys wireless router and as I said I have WEP with a passphrase.

    I hope y'all can help a sistah out.

    Thanks very much,

  2. emt1 macrumors 65816

    Jan 30, 2008
    Get rid of WEP, you might as well have no security at all. If you want security, use WPA or, preferably, WPA2.
  3. waytoofunny thread starter macrumors newbie

    Oct 17, 2008
    thanks - I changed it to WPA with passphrase and I have a complicated one. I still find that airport goes between connecting and a few days later saying it has no IP address....any thoughts?
  4. zachsilvey macrumors 6502

    Feb 5, 2008
    Battle Ground
    I have a connection problem with a linksys router as well. I find the best thing to do is to turn of airport and turn it back on.

    It's true that WEP is not very secure but it is a good preventative measure. The average person doesn't know how to crack WEP and with so many open WIFI access points they aren't going to give the effort to do so.
  5. waytoofunny thread starter macrumors newbie

    Oct 17, 2008

    I find that it only seems to work if i go into my router and change the password.This seems to jumpstart Airport. I also remove the entry in keychain....but doing that alone doesn't do it.


  6. tartarus07 macrumors newbie

    Nov 9, 2008
    I had the same problem when I got my new Macbook. Apparently, WEP codes shouldn't have a problem at all with OS X 10.5. I went through lotsa online checking and made a call to Apple, and the final resolution was that I should set to a WPA code.

    However, that would mean my Nintendo Wifi will lose its connection as well. But for the heck of it I tried to set it to WPA and it worked! Now the problem is that I tried to set back to WEP to get my Nintendo Wifi online but I couldn't.

    In all the hassle, I realised it was because my old WEP 64 bit password didn't work anymore, and it was set to a 128 bit one...the long 20 something character key generated by yr router. And I rekeyed in for all adaptors this key and BINGO! It finally worked for all...So maybe those who are facing the same problem can try this way.

Share This Page