Macbook Internet Issues

Discussion in 'MacBook' started by wr1020, Feb 27, 2010.

  1. wr1020 macrumors regular

    Joined:
    Jun 10, 2009
    #1
    So suddenly my macbook won't load web pages anywhere. I've had this macbook for over a year and have never had an issue with it. I have a windows desktop pc, my macbook, and my dads windows laptop in the house. The pc is hooked up via ethernet to my router and works fine, my dads receiving a wireless signal and works perfectly fine. Now for my mac, it says its connected to my network under network preferences but for whatever reason won't load anything. Sometimes it'll say server not found and other times it just loads ridiculously slow. It took 5 whole minutes to load engadget.com. I've unplugged both my router and modem several times, restarted the macbook, etc and still don't have a solution. Tried different browsers and still nothing. Anyone have any idea why it's suddenly doing this.

    If worse comes to worst i may just have to redo all my router settings and boot it to factory specs but i don't see how it's the router if my dads laptop is getting a signal and my pc is working fine. I'd appreciate any help i can get, thanks.
     
  2. wr1020 thread starter macrumors regular

    Joined:
    Jun 10, 2009
    #2
    So i reset the router to factory specs and setup my network from scratch and of course it still doesn't work. This is really pissing me off. Says its connected to my router and has an IP address. My iphone works perfectly fine too when connected through wi fi, just the macbook that doesn't work.
     
  3. smithmax13 macrumors member

    Joined:
    Jan 27, 2010
    #3
    My wifes macbook had a similar issue, sometimes it would take a long time to load pages, and sometimes it would lose the signal for a few seconds. We're pretty sure that os10.6 fixed the issue. We had tried different routers, different security settings, and anything else we could think of. Everything else we could think of.
     
  4. wr1020 thread starter macrumors regular

    Joined:
    Jun 10, 2009
    #4
    I tried hooking up an ethernet cable to my macbook from my router to check for updates and theres nothing. Still haven't fixed the problem. Is there seriously no one in this forum that knows what this is.
     
  5. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #5
    Did you try resetting the network settings on your laptop and re-connecting to the network as if it were a new network?

    That's all I had to do when I had a similar issue.
     
  6. wr1020 thread starter macrumors regular

    Joined:
    Jun 10, 2009
    #6
    I tried that already and still didn't come up with a fix. I'm guessing this is hardware related because if another laptop and iphone can access the wifi why won't my mac. Under network preferences sometimes it says no ip address then it'll say its ip address is 192.168.1.5. All looks well when it says that yet i still get a server not found. I'm thinking of buying a new wireless router and see if that does anything, if not i'll just return it.
     

Share This Page