Macbook keeps crashing and won't start up

Discussion in 'macOS' started by wilu23, Aug 6, 2009.

  1. wilu23 macrumors newbie

    Joined:
    Aug 6, 2009
    #1
    I've been trying to fix my macbook for couple days now.
    I've erased the entire HDD and installed leopard OS on it.
    I didn't want to install anything on it besides msn since the problem keeps popping up. So basically what happens is safari and msn keeps crashing everytime i start up my mac and try to use them.
    If it doesn't crash, i get a "you need to restart your computer..." screen.
    Now its worse... i get a message right when i turn on my computer:

    panic (cpu0 caller 0x0042F4E3): "Unable to find driver for this platform: \"ACPI\". \n"@/SourceCache/xnu/xnu-1228/iokit/Kernel/IOPlatformExpert.cpp:1378
    Debugger called: <panic>
    Backtrace, Fromat - Frame: Return Address (4 potential args on stack)
    0x41573dd8 : 0x12b0e1 (0x4555b4 0x41573e0c 0x133238 0x0)
    0x41573e28 : 0x42f4e3 (0x49799c 0x4d77720 0x41573e58 0x4de2600)
    0x41573e48 : 0x40d662 (0x4dc0b00 0x4dc0b90 0x1 0x3e80e0)
    0x41573ea8 : 0x40f4f7 (0x4dc0b80 0x4dc0b00 0x4de2680 0x0)
    0x41573f28 : 0x40ed5b (0x4dc0b80 0x4de2700 0x8 0xffffffff)
    0x41573f78 : 0x40d9d7 (0x4dc0b80 0x0 0x41573fac 0x1)
    0x41573fc8 : 0x19e2ec (0x4d774c0 0x0 0x1a10b5 0x4dd88b8)
    Backtrace terminated-invalid frame pointer 0
    BSD process name corresponding to current thread: Unknown

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 9.0.0: Tue Oct ...

    So i've tried the apple hardware test before i got this long message and results were ok.

    macbook is running 2.1ghz core 2 duo, 120 HDD, 4GB ram.

    I've tried switching the HDD and everytime i boot up, it'll give me a "you need to restart your computer..." screen.

    I have an appointment at the genius bar on saturday but if i can fix this before saturday it would be great.

    Any help is appreciated! Thanks!!!
     
  2. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #2
    im no expert, but it sounds like you might be experiencing some problems with the HDD and/or OS itself.

    When you installed the version of Leopard again, did you verify/repair disc, and verify/repair after you installed the OS as well? Sometimes the HDD can act up a bit.

    Also you say, you swapped out the HDD, did you screw up the internal workings, cos sometimes that can have adverse affect on things from an OS point of view.

    Hope that helps

    PTP
     

Share This Page