Macbook Keeps Forgetting My Wireless

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Confuzzeled23, Mar 25, 2009.

  1. Confuzzeled23 macrumors regular

    Jan 27, 2009
    Hey Everyone,
    I have had my Macbook for about two weeks now and I am having a constant annoying problem. Every now and then when I open up my Macbook from sleep it has forgotten my wireless network. When I go into network settings my network is listed, but the computer still says it is not found. However, in the list of available networks that it gives me, it lists mine. I doubt it is supposed to be acting like this. It stays connected fine for a while, no matter if I reboot, sleep, it stays connected. But then at other random times it forgets and I need to reenter my key to connect to my network, even though the key is listed in my keychain access under system, therefore I have had to resort to having a text file with my key saved to my computer for when it forgets so I do not have to go looking for it.

    Does anyone know what would be causing my Macbook to stop recognizing my network and making me have to reconnect and put in my WEP key?

    Hope someone can help, thanks.

    PS - It isn't a router that you need to put in the WEP key over and over because it works fine on my Windows XP dell.
  2. Confuzzeled23 thread starter macrumors regular

    Jan 27, 2009

    I just noticed that it usually does this when coming out of sleep, however if I turn airport off and then turn it back on it connects to my network fine. Strange problem, but I think may have found a temporary fix.
  3. doug.hall macrumors regular

    Jul 28, 2005
    Have you changed the name of the network recently? If you have it could be that you have two options in your keychain and hence the macbook is getting confused. Best thing to do is open keychain (it's in the utilities folder) and delete all passwords in it for any network names you've created. Then go into system preferences, networks, click on Airport and then advanced and remove your current wireless network from your preferred network list. Once you've done this select your wireless network again and then select remember this password and I hope that works...

    I hope that helps and good luck.
  4. cdcastillo macrumors 6502a


    Dec 22, 2007
    The cesspit of civilization
    Just change the security from WEP to WPA, this frequently happens on certain routers (notably 2Wire ones) with WEP and certain macs.
  5. Confuzzeled23 thread starter macrumors regular

    Jan 27, 2009
    Hey Everyone,
    Thanks for the great answers. I tried changing the security to WPA and it seems to be working better. However, I have been trying to go into my keychain, and it allows me to get into my login keychain, but my password is not working to get into my system keychain. I am the only user on the computer, anyone know why I cannot access my system keychain to get rid of the logins?


    UPDATE : Nevermind, strange, it is letting me in now :S

Share This Page