Macbook keyboard in XP

Discussion in 'MacBook Pro' started by EngBrian, Jul 13, 2007.

  1. EngBrian macrumors regular

    Joined:
    Feb 7, 2007
    Location:
    Ontario, Canada
    #1
    I have a macbook and have been trying to work on some excel files in XP using bootcamp. I had a bit of a problem when I tried to divide two numbers because instead of the forward slash all I can get is the é symbol. I would put quotes around that but I am in windows now and they come up as È. In fact most of the symbols on the right side of the keyboard are not accessible.

    Anyone have a solutionÉ (that is a question mark...haha)

    Brian
     
  2. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #2
    Hmmm...did you try the Command or Option keys? Until someone else gives you a better solution, I'll suggest this: just use multiplication. Example: 1/2 would be *.5.
     
  3. EngBrian thread starter macrumors regular

    Joined:
    Feb 7, 2007
    Location:
    Ontario, Canada
    #3
    Yes I tried the control and shift and command and option to no avail. Good call on the 0.5 multiplication but I still need it for some other formulas involving other cells. I am also using *whatever^-1 for divide but that is cumbersome in long formulas.
     
  4. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #4
    Did you try to go to Apple and see if they have a list of shortcuts for this? Although I think it's a software issue. The "?/" key is the same in both OSs, so I don't see why it would be a problem. If it still doesn't work, try to get your hands on a USB data entry board (I hope that's what they're called!).
     
  5. EngBrian thread starter macrumors regular

    Joined:
    Feb 7, 2007
    Location:
    Ontario, Canada
    #5
    I saw something on the page for keyboard mapping but it seemed to be discussing the differences between external keyboard mappings. Maybe I am not typing in the right search criteria but I can't find anything for macbooks. I can't imagine I am the only one having the trouble. I sort of thought that the bootcamp driver disk was supposed to take care of this.
     
  6. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #6
    It is supposed to take care of this. We had macbooks running Bootcamp at school, and all the keys worked like they were supposed to. I think this is an error on Apple's part.
     
  7. EngBrian thread starter macrumors regular

    Joined:
    Feb 7, 2007
    Location:
    Ontario, Canada
    #7
    maybe i will figure out a way to reload the bootcamp drivers. Thanks for your help.
     
  8. CalBoy macrumors 604

    CalBoy

    Joined:
    May 21, 2007
    #8
    No problem. Maybe a reinstall of Bootcamp and a new partition? It seems like a lot of work to do. I would call Apple about this. Taking into a store probably wouldn't help much. Are you still within 90 days of purchase or did you buy Applecare?
     
  9. beginner0 macrumors member

    Joined:
    Jan 23, 2007
    #9
    You might've been using the French keyboard set up. In that case I think Shift-6 would be the question mark?
     
  10. EngBrian thread starter macrumors regular

    Joined:
    Feb 7, 2007
    Location:
    Ontario, Canada
    #10
    So I just tried (Apparently I don't use the windows partition much) reinstalling the bootcamp drivers just by putting the disk in and it reloaded everything but no change. I was testing functionality in Word and noticed at the bottom of the word window that it said French...

    I thought this was weird since my regional settings in windows were for canada with english keyboard and US layout. But for some reason there was a french keyboard also listed in the regional keyboard settings and it was the default. It said it was the "apple" keyboard. So I don't know how it happened but Bootcamp was telling windows to make a french keyboard the defauly. So Beginner0 you win the prize (even though I only found out you had written at all after the problem was solved...figures! haha).

    So to conclude the thread if anyone has this problem again make sure that in the regional settings (in the control panel) that a french layout keyboard hasn't been added by bootcamp.

    cheers and thanks all for your suggestions.
     

Share This Page