Macbook keyboard/mouse is causing gibberish/being unresponsive.

Discussion in 'Mac Basics and Help' started by Rikos87, Oct 11, 2009.

  1. Rikos87 macrumors newbie

    Joined:
    Oct 7, 2008
    #1
    My mom's Macbook keyboard has been acting erratically as of late. At first the keyboard was giving text that could only be used when holding down the option key. I turned off the option key and it worked for a while. An hour later the keyboard starts showing gibberish again and it's unresponsive. I have taken into account that periodically that my mom wipes down the keyboard but it doesn't seem to be a problem of sorts, though I'm not ruling that out.

    Any other Mac users have had this problem before?
     
  2. SonicSoundVW macrumors regular

    Joined:
    Jul 22, 2014
    Location:
    Michigan, USA
    #2
    know this is a very old post but i just posted this at apple support.

    I guess this problem has never been solved but i thought i would let people know I'm having this problem to see if anybody has found a fix for it. I am using a MacBook Pro Retina (mid 2012). When i use the wired keyboard a s d f g h j k l looks like å ß ∂ ƒ ˙ ∆ ˚ ¬ . I have tried just about everything i can think of besides buying a new keyboard and seeing if it is the keyboard itself. Anybody else have a similar problem or possibly a fix. DO NOT tell me to try another computer, make sure the USB ports are working, try a windows PC, try a different Mac, reset the SMC or PRAM, check fonts for duplicates. It does the same thing on a mac mini, and in windows it acts like control or alt is being held down. One would think that would make it like the keyboard is at fault, but at one point in time tonight during my adventures on learning how to troubleshoot a APPLE keyboard on an APPLE computer it worked about 80% except for several keys would type two letters when one was pressed. b = bn . Im out of ideas besides buying a new keyboard and crossing my fingers.
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    Brobdingnag
    #3
    Frankly, all those symptoms sound like the keyboard itself is at fault.

    The fact that it's a separate standalone keyboard, and you tried it on two different computers and got similar results is really pointing the finger at the keyboard. At first I thought you were talking about the rMBP's builtin keyboard, but then I realized I'd misinterpreted "It does the same thing on a mac mini".

    Just because the problem is intermittent doesn't eliminate the keyboard as a possibility. Grunge buildup and electrical miscontacts can be intermittent.

    If it were wireless I'd say "check the battery", or even "check the battery contacts for corrosion". The fact it's wired USB eliminates that.

    Simple and obvious solution: get a new keyboard.

    If you don't want to do that right away, try borrowing a USB wired keyboard from someone. If that works, it's pointing even more strongly at the keyboard itself being the problem.

    There may be something fixable if you opened the keyboard case and cleaned it out really well, but unless you're halfway skilled with cleaning electronics, that's still a gamble. You could still try it after you get a new keyboard, when there's nothing to lose if a cleanup goes wrong. Or you could risk it without having a new keyboard at hand, as I assume the rMBP builting keyboard still works.
     
  4. SonicSoundVW macrumors regular

    Joined:
    Jul 22, 2014
    Location:
    Michigan, USA
    #4
    AH yes indeed. Weirdest keyboard fault I've ever seen. lol It was in fact the keyboard! Im going to take the other one apart and or use the air compressor and dust it out to see if i can't get it working again. yes the built in keyboard works, i should have been more clear, i apologize. Thanks for the input! :)
     
  5. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    Location:
    Brobdingnag
    #5
    In my experience, keyboards usually need more than just a compressed air dusting. The oils from hands causes more of a "gunk" buildup than a simple dust buildup. Yeah, there's dust, too, but the oil makes it stickier and harder to clean out.
     
  6. Joined:
    Nov 20, 2017
    #6
    Yo, I'm well aware you posted this question over 4 years ago but for people desperately googling still - I just figured out it was because my keyboard switched to "French" language input mode. A co-worker had added it as an option in the past one day to my keyboard settings (as another option) and sure enough it was switched on accidentally I figured out. Finally. As I was super confused why my "a" button was outputting the letter "q" etc etc.

    In fact, per googling, the shortcut could easily slip on if you're a wild typer and have added / used another keyboard language setting in the past. Once another language has been added, it's as easy as having a cat walk across your keyboard to to activate the shortcut. i.e. "keyboard shortcuts: Press Option-Control-Space bar to select the next input source in the Input menu, or Control-Space bar to select the previous input source


    TO FIX: Choose Apple menu > System Preferences, click Keyboard, then click Input Sources. Choose english or whatever your usual language is and see if that was the issue. I suggest deleting other languages not in use, because:


    Once you have more than one option in the keyboard languages, the shortcut "Option-Control-Space bar" (then maybe a cat sits on the laptop and/or some sort of "oops" "what?" "enter" (or something to that effect) will accidentally change your keyboard language functioning for you.

    Side note: This is a great April fool's prank to pull on someone who has a good sense of humor and isn't on a critical deadline. So is removing the track ball out of the mouse when they're not looking (as my friend Alan taught me one frustrated day in class.)

    --- Post Merged, Nov 20, 2017 ---

    Yo, I'm well aware you posted this question over 4 years ago but for people desperately googling still - I just figured out it was because my keyboard switched to "French" language input mode. A co-worker had added it as an option in the past one day to my keyboard settings (as another option) and sure enough it was switched on accidentally I figured out. Finally. As I was super confused why my "a" button was outputting the letter "q" etc etc.

    In fact, per googling, the shortcut could easily slip on if you're a wild typer and have added / used another keyboard language setting in the past. Once another language has been added, it's as easy as having a cat walk across your keyboard to to activate the shortcut. i.e. "keyboard shortcuts: Press Option-Control-Space bar to select the next input source in the Input menu, or Control-Space bar to select the previous input source


    TO FIX: Choose Apple menu > System Preferences, click Keyboard, then click Input Sources. Choose english or whatever your usual language is and see if that was the issue. I suggest deleting other languages not in use, because:


    Once you have more than one option in the keyboard languages, the shortcut "Option-Control-Space bar" (then maybe a cat sits on the laptop and/or some sort of "oops" "what?" "enter" (or something to that effect) will accidentally change your keyboard language functioning for you.

    Side note: This is a great April fool's prank to pull on someone who has a good sense of humor and isn't on a critical deadline. So is removing the track ball out of the mouse when they're not looking (as my friend Alan taught me one frustrated day in class.)
     

Share This Page