Macbook late 2008 aluminium, SMC Problem?

Discussion in 'MacBook' started by omar84, May 15, 2017.

  1. omar84 macrumors newbie

    Joined:
    May 15, 2017
    #1
    llo, I have a Macbook aluminium late 2008, with bootcamp with Windows 7, and I have a problem with it.



    Last year it starts with an error that sometimes when I turned on the pc, the Sleep Indicator light automaticaly turns on and after loading and introduce the pasword and appear the desktop it automatically goes to sleep mode, and I press one key and wake up. but it was once every 10-20 times I strart the pc. other times it works perfectly, the battey is nearly dead only last for 15-20 minutes. but as I usually use it at home is not problem for me.



    The problem starts about 6 months ago when everytime y try to start, the SIL light turns on always and in MacOS mode it apprear the password screen and the backlight of the screen turns off inmediatly and sometimes it goes to sleep mode , I press one key and wakes up,but backlight light does not turns on anymore,I know because I can see the screen If I put a torch behind the screen where a apple logo. The strange thing is that If I turn on in Windows mode, there is no problem and works ok despite the SIL light is always on.



    I have tried most of everything, Reset SMC, PRAM, taking out one Ram...... I have read a lot of things, but I have no solution, the last thing I Did is to format the Hard disk and reinstall everything, but it still the same.

    I try to run the Laptop without hard disk and the SIL light still on.

    The only way I can make it runs in MacOs mode is using the single user mode (or something like that is calle) that I run into that mode taking out the baterry and the magsafe connector, and press the on button while conecting the Magsafe conector again. That makes the fans run 100% and works most of everyting in MacOS but I can not load in windows mode it gets stuck on the loading window.



    I think the problem must be with some sensor or problem with the EFI or SMC firmware. I try to install the firmware update but it says that I do not need the update because it is update, is there any way to downgrade the firmware or reinstall it?

    I do not have the DVD or CD and I do not know if they came with my mac because my brother does not remember.

    I remebeber when it began the problems I used the INSOMNIAX and it works great but now it does not do anything and I can not use my macBook in MacOS,

    Anyone who knows what is happening?



    thank you very much.
     
  2. ryguy92000 macrumors regular

    ryguy92000

    Joined:
    Sep 20, 2014
    Location:
    Salt Lake City, UT
    #2
    These machines are so old it wouldn't surprise me if board components are starting to fail. If you suspect an SMC after all your efforts you are likely correct. Meaning replace the machine, you will be better off anyway.
     
  3. omar84 thread starter macrumors newbie

    Joined:
    May 15, 2017
    #3

    Thanks for your answer, I think Is the firmware or a problem in a component because the windows error log says that there is a problem I have also the log of the MacOs I will post it later. Here I attach the windows 7 error. Later I will upload the MacOs log.

    But the problem is that I do not know how to reinstall o downgrade the efi and smc firmware
    Thanks again for your answer.
    --- Post Merged, May 17, 2017 ---

    I attach the log in Mac os you will see lots of hybernate and wake but It goes automatically to hybernate an I have to wake up
     

    Attached Files:

  4. omar84 thread starter macrumors newbie

    Joined:
    May 15, 2017
    #4
    Hello again and thank you for your answers.

    Finally I find out what the problem is.

    It has damaged the sleep sensor (or stucked) . The one under the hard disk . The Ir/ sleep sensor. I unplugged it from the logic board. And it works great. I asked one to replace it and let you know.
     

    Attached Files:

Share This Page