MacBook (Late 2008) external monitor woes

Discussion in 'MacBook' started by Vivaldi, Jul 27, 2009.

  1. Vivaldi macrumors member

    Joined:
    Jun 13, 2008
    Location:
    Manhattan, NYC
    #1
    I have a MacBook (Late 2008) that's been using an DVI-based external monitor (Mini-DVI — DVI converter) for the past few months. It's been working well up until today, when at startup the monitor remains black after the Apple and spinning gears. According to the monitor, there is indeed a signal coming through, and interestingly if I connect the monitor to the computer, the MacBook screen flashes blue constantly until I remove the monitor cable.

    Any clues as to why this is happening? Thanks for any input.
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Has your mini-DVI port started feeling different lately, like it used to click and now doesn't?

    That was a problem some experienced a little while back and will be covered by your warranty. The other thing you can do first is try resetting your PRAM.
     
  3. Vivaldi thread starter macrumors member

    Joined:
    Jun 13, 2008
    Location:
    Manhattan, NYC
    #3
    I haven't noticed anything in regards to the guiding of the port/converter, so I'm not sure if it is indeed a port problem or not. However, a PRAM reset did nothing of any value.

    Tomorrow I think I'll drop by an Apple Store to see if it can be repaired. How long does the repair usually take?
     

Share This Page