MacBook ((late 2009) don't turn on.

Discussion in 'MacBook' started by nadro-linux, Jul 22, 2011.

  1. nadro-linux, Jul 22, 2011
    Last edited: Jul 22, 2011

    nadro-linux macrumors newbie

    Joined:
    Jul 22, 2011
    #1
    Hi,

    I have a problem with my MacBook 13'3 (late 2009) which can't turn on. Today I installed new Lion OS and Ubuntu... When I press power button diode is white, but display is still black, fan is running. When I reset SMC sometimes MacBook turn on, but after shutdown and next run diode is blinking for 3 seconds, I have one long beep signal and no other effects (display is black etc.). On power supply diode I have orange colour, so it's fine I think (battery isn't fully loaded). I replaced RAM (now I have 2x 2GB Kingston 1066, but it works fine for 2 months). I tried with one RAM in differents slots and withou Hard Drive but I see the same effects. My warranty expired 4 days ago...

    Cheers,

    Update:
    MacBook turn on fine and works without any problems (I checked stability in OpenGL 3d application and is ok) every each 4 tried. After shutdown I have as I said before when my MacBook is running diode is shine for ~2 seconds, next is fast blinking for ~2 seconds, and after it is shine, but I have long one beep signal when diode is back to shining. Now I must 3x power on and power off and after 4th power on MacBook will running and it's working fine. Maybe are You know how can I solve this problem?
     
  2. nadro-linux, Jul 23, 2011
    Last edited: Jul 23, 2011

    nadro-linux thread starter macrumors newbie

    Joined:
    Jul 22, 2011
    #2
    I found a solution:
    http://www.youtube.com/watch?v=qPoU8838KDo

    I have got the same error, one problem is that for MacBook6,1 Apple didn't release firmware update for my model :/ Can someone send me a working firmware from Your MB6,1? It's located on hidden EFI partition: /EFI/APPLE/EXTENSIONS/Firmware.scap

    Cheers,
     
  3. spartus4 macrumors newbie

    Joined:
    Jun 12, 2009
    #3
    Did you try resseting the PRAM. I see you did the SMC but that is only one part. Try holding down command+option+P+R as you power it up and keep holding until is restarts and release after the chime. I don't know if this will help, but it's worth a try.
     
  4. nadro-linux thread starter macrumors newbie

    Joined:
    Jul 22, 2011
  5. nadro-linux thread starter macrumors newbie

    Joined:
    Jul 22, 2011
  6. thedoc.tar macrumors newbie

    Joined:
    Aug 1, 2012
    #6
    I have a Macbook6,1 aka "MacBook(late 2009)". I too was very disappointed that no firmware update was available for my model. I know that it has the same guts as the Macbook pro that was releases at the time, but i don't know which one it is. My hope is that i can somehow manually install that firmware onto my macbook.

    Any suggestions?
     

Share This Page