MacBook Light Steady in Sleep Mode

Discussion in 'MacBook' started by thelatinist, Aug 18, 2009.

  1. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #1
    My MacBook light no longer pulses gently when the computer goes into sleep mode after the cover is closed. This doesn't seem to be affecting battery life, so it is clearly going into sleep mode as always. It's not a huge problem, but I was wondering if anyone else has seen it.

    Note: I believe I first noticed this problem after the computer froze during an update. But the system software has been updated several times since, with the same results.
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Have you tried resetting the PRAM and SMC? How about Repairing Permissions?
     
  3. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #3
    so, what does the light do? turn off or just stay on??

    if it turns off then its going into "deep sleep", if it stays on then its not going to sleep at all! :eek:
     
  4. thelatinist thread starter macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #4
    I had tried repairing permissions, but not resetting PRAM. I didn't think the 2008 polycarbonate MacBooks had SMC; am I mistaken?

    The light stays on, but I believe the computer is going to sleep because the battery life is unaffected (it does not discharge like it is awake).
     
  5. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #5
    IIRC, you are mistaken-worth a try anyway.

    how odd!! :eek:

    have you tried checking for any updates? or have you upgraded to 10.5.8, that might have caused it?
     
  6. thelatinist thread starter macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    I've now tried the PRAM and SMC, no dice.

    I am running 10.5.8, but I believe the issue first showed up when my 10.5.6 upgrade froze mid-update. Two upgrades later and it's still steady. Since it's not affecting battery life, I don't feel it's worth reformatting and reinstalling.
     
  7. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #7
    Seeing how it happened due to a system update, you can try re-installing 10.5.8 from the Combo Updater as opposed to the incremental updater.

    Sometimes that'll clear up issues that came up from previous revision updates.
     
  8. thelatinist thread starter macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    Tried the Combo Updater, no change. Thanks to everyone for their suggestions. I know it's a relatively minor thing, but it is an annoyance.
     

Share This Page