MacBook Mag Safe "flaky" battery charging....

Discussion in 'MacBook Pro' started by mtbdudex, Sep 11, 2007.

  1. mtbdudex macrumors 68000

    mtbdudex

    Joined:
    Aug 28, 2007
    Location:
    SE Michigan
    #1
    I did a search on this forum for "Mag Safe" and could not find a thread for my issue, if there is one please point me to it, thx in advance.

    Help me!

    We bought our MacBook last year, May 2006, it is out of it's 1 year warranty.
    It is used as home computer. We love it, our 5 and 3 year old love it.

    Had zero problems with it until 3 weeks ago, the Mag Safe plug/charger is working "flaky". By that I mean when I plug it in, sometimes it does not light up green or orange at all. If I jiggle the cord or flip it over then it will seem to "connect" and turn green for a few seconds then orange to indicate re-charging. Yet, the battery does not charge most of the time. I can't believe the battery is "dead". My wife removed the battery and it works fine directly from the Mag safe line.
    Any thoughts?
     
  2. freshwunder macrumors newbie

    Joined:
    Jun 25, 2007
    #2
    Im having the same problem with mine - and I just bought it in October. It will charge sometimes, it won't sometimes...it will work when plugged in, just won't charge.
     
  3. mtbdudex thread starter macrumors 68000

    mtbdudex

    Joined:
    Aug 28, 2007
    Location:
    SE Michigan
    #3
    Ok;

    I reset my MacBook by;
    -shutdown
    -removing battery, unplug
    -push/hold power on 7 seconds
    -install battery, plug in
    -restart

    Hoping this fixes whatever is keeping it from charging.

    Also, for the past two/three weeks we've been having this bouncing "superdrive update 2.1" trying to do some install, then when I click on it the dialog box reads "no updatable devices found", I click quit. Upon next restart it come back again. Strange.

    Back to the battery issue, using system profiler, does this indicate anything?
    System Power Settings:

    AC Power:
    System Sleep Timer (Minutes): 60
    Disk Sleep Timer (Minutes): 180
    Display Sleep Timer (Minutes): 45
    Automatic Restart On Power Loss: No
    Wake On AC Change: No
    Wake On Clamshell Open: Yes
    Wake On LAN: Yes
    Display Sleep Uses Dim: Yes
    Battery Power:
    System Sleep Timer (Minutes): 15
    Disk Sleep Timer (Minutes): 10
    Display Sleep Timer (Minutes): 5
    Wake On AC Change: No
    Wake On Clamshell Open: Yes
    Display Sleep Uses Dim: Yes
    Reduce Brightness: Yes

    Battery Information:

    Battery Installed: Yes
    First low level warning: No
    Full Charge Capacity (mAh): 4219
    Remaining Capacity (mAh): 0
    Amperage (mA): 67
    Voltage (mV): 10077
    Cycle Count: 219
     
  4. phantasmagoria macrumors regular

    Joined:
    Nov 15, 2006
    Location:
    UK
    #4
    Did anyone manage to resolve their problem? My MBP has started doing exactly the same thing...

    When I plug in the charger it will sometimes lights up green, sometimes amber and sometimes not at all. When it does come up amber, it's still not charging most of the time without jiggling or re-inserting the charger. Very annoying...
     
  5. annexw macrumors newbie

    Joined:
    Dec 4, 2006
    #5
    I had something similar happen (sometimes it would turn green, sometimes amber, sometimes no light would come on etc etc)

    I took it to the repair shop, they tried another charger and same deal.

    Ended up having the logic board replaced. All under warranty, so that was good.

    So try another charger (go to a local apple store or anywhere carrying Apple laptops and just ask to try. Most places selling Apple have one or two on demo). If it still happens, you are probably looking a repair.
     

Share This Page