MacBook MagSafe doesn't work

Discussion in 'MacBook' started by Keitto, Feb 2, 2009.

  1. Keitto macrumors newbie

    Joined:
    Feb 2, 2009
    #1
    Hi,

    I looked around the forum and found similar posts, but none of them with the exact sympthoms.

    Here's the thing. A friend gave his MacBook for me to restore it, because it was taking to long loading the OS and any application he wanted to use. So I erased to zero and installed Leopard 10.5.1 (this MB comes with Tiger). Everything went fine and OS was fast again.

    After I finished installation and upgraded to 10.5.5, I noticed the MagSafe light was off and the MB was using the battery.

    My guess is I need to update some firmware or something like that, because the MagSafe was working perfectly during installation.

    These are the specs of the laptop:

    MacBook White (MacBook 2,1)
    2.16GHz Intel Core 2 Duo
    L2 cache: 4MB shared
    System bus: 667MHz
    1GB (two 512MB) of 667MHz DDR2 SDRAM
    120GB Serial ATA; 5400 rpm

    Should I run Firmware Restoration CD 1.4 or maybe install Tiger again? :confused:

    Best regards,
    Keitto
     
  2. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #2
    Resetting the SMC: http://support.apple.com/kb/HT1411

    Updating the SMC Firmware: http://support.apple.com/kb/HT2368

    Try those (in that order, reset it first, if it works, you can elect to do the upgrade if you choose), let us know how it goes.
     
  3. Keitto thread starter macrumors newbie

    Joined:
    Feb 2, 2009
    #3
    Ok, I've resetted the SMC, but it didn't work (MagSafe light still off). I looked for the SMC update, but there is none for MacBook (Mid 2007); there is one SMC update for MacBook (13 inch) that is 1.4f12 (SMC1.1), the other one is for a MB Aluminium. Actual SMC version is 1.17

    Boot ROM is up to date, btw.
     
  4. Keitto thread starter macrumors newbie

    Joined:
    Feb 2, 2009
    #4
    Turns out the charger is kaputt. Today I plugged it to another MacBook and didn't work. Use the other laptop's charger and light is orange.

    Thanks for your support. Cheers.
     

Share This Page