Macbook Mid 2007 with SSD

Discussion in 'MacBook' started by HankBukowski, Nov 6, 2013.

  1. HankBukowski macrumors newbie

    Joined:
    Jul 11, 2013
    #1
    Hello all

    My set up:

    MacBook Mid 2007 Core 2 Duo
    2 GB Crucial RAM
    64GB Crucial SSD
    No operating system

    Non-Retina MacBook Pro Mid 2012
    8GB Apple fitted RAM
    500GB HDD
    10.8.5

    Both Macs where running perfectly but in my infinite wisdom i decided to swap the drives so i could just have the MacBook set up at home storing all my music, video, photos etc and use this solely for connecting to Apple TV. Then put the SSD in the Macbook Pro for everyday use.

    All this went perfect and was running fine. Then i tried to install Ubuntu on the Macbook Pro SSD, after several attempts and reading about the problems with my particular Macbook Pro and Ubuntu I gave up but not after wiping the SSD a few times trying to install Ubuntu.

    So I wiped the SSD, reformatted, 1 partition, GUID etc. then removed the SSD and put the original HDD back in the Macbook Pro and it is ok and running as it should.

    I then put the SSD back in the Macbook. When I did this I took the keyboard off to check connections and give it a bit of a clean then put the drive in and booted up holding down option with a copy of Lion on a separate USB stick. QUESTION MARK FOLDER TIME. DOH!

    Tried all the usual (resetting NVRAM/PRAM, SMC Reset etc.) SSD boots in an external case on MacBook Pro and I can see it in Disk Utility.

    OK, I'm thinking, could there be some issue on the SSD regarding me trying to install Ubuntu? Maybe some 'left over' data from Ubuntu? I did notice that when i reformatted in DU on MBP that when it finished there is 5GB or so that wont wipe?

    Could i have damaged something inside the MacBook? This Macbook had new logic board, keyboard cover, screen etc. only 18 months ago (Apple broke the original components while fitting a free cracked palm rest so replaced the whole guts of it.)

    Does anyone know why this could be happening? SSD bad? Ubuntu data? Problem with Mac i may have caused?

    Hope someone can help me

    Regards
    Hank
     
  2. WildCard^ macrumors regular

    Joined:
    Oct 11, 2013
    #2
    I don't know how to fix your issue, but if it did give you problems erasing 5GB, I would consider pulling it out and, with a USB adapter, hook it up to a working machine - then do a full format.

    It could be the SSD, but would be a coincidence. I googled for 'SSD health check' and came up with this link at a respectable tech site:
    http://www.tomshardware.com/forum/286044-32-program-checker-health-status

    Guessing it's healthy, but just needs a full, not quick, format.
     
  3. HankBukowski, Nov 6, 2013
    Last edited: Nov 6, 2013

    HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #3
    Thanks for the quick reply WildCard. The SSD is now in an external USB 3.0 enclosure. I looked at the link and it seems Speedfan is Windows. No? I will search for a hardcore SSD Disk Checker for Mac. Anyway, this is what i've tried up to yet using my MBP.

    I now have the SSD in an external USB plugged in to my MacBook Pro

    I go to DU and select the drive and Verify Disc. All OK except also mentions an EFI partition? Isn't that something to do with Ubuntu?

    Then I Erased. All OK.

    Then i partition the drive, 1 Partition, GUID etc. OK except there is still a small blue partition and in the yellow hover info box it says '58GB Available from a formatted 65GB? Is there something else on it I can't get rid of and hence stopping me installing Lion on it? AFTER Partitioning has finished i get 'selected partition won't be changed'. It looks basically like 58GB of the disk is fine but this other (i don't know where) 6GB is storing something on the SSD that I cannot get rid of.

    Will go and look for a program to double, triple, super dooper, robocop eraser tool, if anything exists?

    Anyone?

    Regards
    Hank
     
  4. WildCard^ macrumors regular

    Joined:
    Oct 11, 2013
    #4
    I believe you should be able to install any OSX on a completely empty drive. The installer will format as necessary. Just yesterday I did a reinstall of SL, wanted the drive erased, so did that in DU. Once erased, I contemplated setting up partitions and such, but opted instead to see if the installer would take care of it, thinking it would set it up in an optimal way. I was correct, it did everything.

    So now that you erased the drive and all partitions on the SSD while in the external enclosure, time to reinstall the drive and reinstall Lion.

    Don't be bothered by the 65GB formats to 56GB. Erase everything and let Lion installer take care of the setup!

    Did the SSD test healthy?

    Hope it helps.
     
  5. HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #5
    Screen Shot 2013-11-06 at 23.26.32.png

    OK, I agree with everything you suggest so I went to DU and Erased the drive, back to Repair Disk and it repairs OK but hasn't fully erased the disk. You can see in the screen shot even after repairing, verifying, erasing and partitioning 2 or 3 times in different combinations still there is EFI and Windows sh*te STILL on it.

    Its my fault for trying to fix things that aren't broken.

    The SSD shows in Finder in OS X ML on my MacBook Pro and I can transfer files to and from it.

    I have Lion 10.8 on a USB so rebooted holding down option key but just get my internal HD, Recovery 10.8 and Lion Disk Installer USB (which obviously is no use because there is no SSD showing to install it on to.

    Becoming quite a challenge now. Gonna contact Crucial and ask how I can wipe the EFI and Windows stuff. EFI is a boot process for Windows/Ubuntu I think???

    Whatever it is i just want it off!!!

    Will have another Google then phone Crucial and just say "look, I've got in over my head with this, will you tell me how to wipe it properly please" It's only 2 months old and I've knackered it lol. Hopefully solvable, is that a word?

    Regards
    Hank
     
  6. HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #6
    Lion 10.7 Sorry

    ----------

    This looks very good, DriveDx, http://binaryfruit.com/drivedx Free 10 day trial, so I just checked my Internal HDD but doesn't support external drives. Grrr

    The hunt goes on…..
     
  7. HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #8
    Found this article

    http://malcontentcomics.com/systemsboy/2012/03/securely-erasing-a-mac-ssd.html

    It's more about secure deleting an SSD but if I was surprised by this one. You log onto your iCloud account on another computer then using Back to my Mac you can securely delete and totally wipe your SSD….Remotely. Article is old but the guys done it and it obviously works. Dangerous if someone gets your iCloud password though. Anyways this doesn't help me now as the SSD has no OS on it. But a good way and secure way to wipe drives.

    Will resume a solution tomorrow. Jeez!!!

    ----------

    Thanks again WildCard, I will look at the links tomorrow. 1am here!

    Many thanks again for your input!
    Hank
     
  8. WildCard^, Nov 6, 2013
    Last edited: Nov 6, 2013

    WildCard^ macrumors regular

    Joined:
    Oct 11, 2013
    #9
    glad to help! I don't think you need to do anything icloud related to remove it.. If you can't do it in MAC, might have to plug it into a Windows box and blast it away.

    Catch you tomorrow. Looking forward to hearing how you get it done.
     
  9. HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #10
    Update:

    From Googling I found iPartition. Reading about it i 'think' this is what i need, but it's above my pay grade and before i pay for it does anyone know if it will work?

    I have used Terminal to issue the following commands

    http://themacadmin.com/?p=603

    http://apple.stackexchange.com/questions/57597/how-to-fix-broken-efi-partition (thanks, WildCard)

    I seemed to be able to follow this OK but when I have done this I STILL can't install Lion OS X on the drive. When i resart holding 'option' the drive still does not show. Is there anything more I have to do when I have followed the above commands on the macadmin site?

    Onwards and upwards
    Hank
     
  10. WildCard^ macrumors regular

    Joined:
    Oct 11, 2013
    #11
    Hey Hank,

    That second link was informative to me. So, did you compare the EFI values as shown in the second link when they did the:
    "You can read the GPT using the command
    Code:
    sudo gpt -r show disk0
    in a Terminal window, this produces output"​

    It seems as if the problem is likely a bugged EFI partition. Knowing what the GPT command gave you above and if it matched the link's output will confirm that. Then using the next two commands to delete and recreate it should fix it.

    If you did that, my next step would be to blow it all away by plugging it into a windows machine. Disk Manager would allow you to delete any and all partitions. Then taking that virgin drive back to the MAC to see if Lion installer can deal with it should be successful.

    I am a MAC noob, I am sure there is a command that /should/ wipe the drive in OSX, but I don't know it. As a PC guy natively, I can confirm that Disk Manager is where I go before all reinstalls - wipe all partitions and let the OS installer recreate everything it needs from scratch. I can not recall one time this has failed me, and my line of work and age has had me reinstall windows hundreds of times.

    This was longer than I expected.
    TL;DR: did the GPT command look like it should?

    WC

    PS: don't buy anything yet. I think you are || this close to solving it.
     
  11. HankBukowski thread starter macrumors newbie

    Joined:
    Jul 11, 2013
    #12
    Hey WC

    Thanks for that. I have also emailed Crucial to ask how to do it. I will have a play around this weekend with the Terminal and take it to a friend who has a PC and try what you suggest. Hopefully that will bring some results back and come Monday Crucial should have replied.

    Thanks for your help and have a good weekend.

    PS If anyone wants to chip in you are welcome. hint hint!!!

    Regards
    Hank

    ----------

    Also i sent the link to this thread to Crucial so hopefully they'll have a look before replying.
     
  12. WildCard^ macrumors regular

    Joined:
    Oct 11, 2013
    #13
    Do you still have the external USB enclosure? If so, you don't have any Windows machines you could plug it into for a moment?

    I am impatient and don't want to wait for Monday. heh
     

Share This Page