Macbook Mid 2010 Cannot Install OSX

Discussion in 'MacBook' started by JonnyAlpha, Oct 23, 2018.

  1. JonnyAlpha macrumors regular

    Joined:
    Oct 30, 2008
    #1
    Hi,

    According to my research I am trying to fix my son's MacBook Core 2 Duo 2.4 13” (Mid 2010). (P8600) A1342.

    He does not know what happened just that it would not boot. Apple Logo appears, progress bar takes forever then on top of the whit screen with the Apple Logo on white text appears in a black background and the Macbook restarts - again and again until you power it off.
    the text said something about Kernel Panic?

    Anyway - I have managed to create a USB install device using an 8GB USB Stick and have copied El Capitan across to it following one of many guides on how to do so.

    I started the Mac and pressed 'Option' at the chime and managed to select the USB Install Disk to install the OS.

    From the Startup Menu I could choose to install OS X El Capitan but at first it failed saying that it could not verify the download. I fixed this by changing the date from 2001 to the day the OS was downloaded. I managed to get all the way through the install but at the very end (0 seconds) it failed again with a another verify error?

    I have tried resetting SMC and PRAM, and lots of other things but it is becoming frustrating because everytime I try something new it takes forever to get a menu up on the screen?

    Just now I managed to get it to boot using CMD + R but when I tried to select the target disk for the install it said I could not use it as the drive had SMART errors. (This was the original drive that was in the machine). I have now put in a different drive and now the machine just powers off after waiting for the progress bar to finish?

    What is left to do and how do I progress?

    Couple of associated questions:

    1. When booting using 'Option' should both the external USB device and the internal HDD show? With the latest spare HDD installed only the USB OS install device is shown, the internal HDD is not visible? When I select the OS Install Device to boot the Apple Logo appears and the progress bar moves along slowly before powering off
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Could it be a bad hard drive cable inside the Macbook?

    Tried installing the OS to and booting from an external drive?
     
  3. JonnyAlpha thread starter macrumors regular

    Joined:
    Oct 30, 2008
    #3
    I am normally pretty good at fixing these kinds of issues but everything about this just gets harder

    Now having trouble installing an OS onto an external HDD. Guides are a bit hit and miss or there are steps that I cannot follow due to some sort of incompatibility. I have a copy of the Mavericks Installer and tried to run that to select the external HDD as the target but it won’t let me run it saying that it’s too old (I am running High Sierra on the host machine).
    I then found a guide to get around this by using restore in Disk Utility but that’s where it fails, the version of Disk Utility is older and it says to locate a file called installESD.dmg which I cannot find. The guide however is talking about Mountain Lion not Mavericks.
     
  4. JonnyAlpha thread starter macrumors regular

    Joined:
    Oct 30, 2008
    #4
    Not tried an external HDD yet. I guess that would confirm that the Mac itself is ok?

    Can't install an OS to an external HDD but I have just created another OS Installer using a USB HDD. It has got El Capitan on it (a newly downloaded version from the App Store.

    I tried using Diskmaker but it got into all sorts of problems with different versions. After looking at the FAQ I found a link to these guides. Instead of using my possibly dodgy 8GB Verbatim USB Stick I used a spare 320GB WD HDD in an external enclosure.

    https://www.lifewire.com/perform-a-clean-install-of-os-x-el-capitan-on-your-mac-2259940

    https://www.lifewire.com/create-emergency-os-x-boot-device-2260173

    https://www.lifewire.com/make-a-bootable-usb-drive-of-yosemite-installer-2259931

    So far I have managed to successfully boot from the Eternal HDD, Erase (Again) the internal HDD and start the install. The first phase has finished and the Mac has re-booted and is now the progress bar is at about 14 minutes remaining.

    We will see.
    --- Post Merged, Oct 23, 2018 ---
    Think it's just rebooted again and progress bar is half way again?
     
  5. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
  6. auhagen macrumors regular

    Joined:
    May 30, 2010
    Location:
    Denmark
    #6
    I have the exact same model and tried something similar to you. I tried everything, and the machine would always fail somewhere at the install. Then I took the machine apart and changed the internal cable for the hard drive, and the machine have been running ever since. The part costed me less than 20$ and with a SSD in the bay the machine felt like new.
     
  7. AnonMac50 macrumors 65816

    Joined:
    Mar 24, 2010
    #7
    Check the date and time? I had a similar problem with 2010 MacBook Pro and I needed to change the date and time in terminal. Otherwise it was too slow and I wasn’t really able to install anything either.
     

Share This Page

6 October 23, 2018