MacBook 'Missing' Harddrive Space

Discussion in 'MacBook' started by jjames1000000, Nov 20, 2012.

  1. jjames1000000 macrumors newbie

    Joined:
    Nov 19, 2012
    #1
    I know this comes up a lot, and I've gone through many other posts on this topic, but I seem to be 'missing' space on my harddrive. I've got a Retina MacBook Pro, 500GB SSD.

    I've got screenshots below of the programs I've used (sorry I don't know how to put an image within the text).

    Basically, going About This Mac > More Info > Storage, I get the bar graph showing 193.0 GB of 'Other', and 96.21 GB of Free Space. I had wondered if this was being used by Time Machine Local Snapshots, which I understand 'delete themselves' as you add more data to your drive, so I started filling my computer with movies, but it only let me add 96 GB, ie the Free Space. So it's not Local Snapshots.

    I then ran Disk Inventory X, which shows the data on my drive taking up 251.5 GB, which should leave ~250 GB Free Space, so taking away the 96 GB that's definitely Free, it leaves ~150 GB 'missing'.

    I then scanned my drive with Daisy Disk, which shows the data on the drive taking up 403.1 GB (which leaves ~96 GB Free, so that's all good), but when you add up the numbers on the right of the image, they only add up to 267.3 GB - 135.8 GB missing...

    Finally I've used Omni Disk Sweeper, which shows 267.5 GB of data (which agrees with Daisy Disk). I then found this site:
    http://www.macobserver.com/tmo/article/how_to_recover_missing_hard_drive_space/
    That shows 276.2 GB of data, so while it's a little larger, I'm still missing about 130-150 GB of data.

    One thought I've had is that it's 'leftover' space from Parallels. I installed Parallels recently, had some trouble with it, uninstalled it, reinstalled it, but the problems persisted, so I uninstalled again. I'm thinking that may be the problem?

    If anyone can help it would be greatly appreciated!
     

    Attached Files:

  2. Barbara2956734 macrumors newbie

    Joined:
    Apr 12, 2013
    #2
    I found it

    Hi

    I had the exact same problem & managed to solve it myself by searching through forums

    Here's what i did

    This is what I did:



    https://discussions.apple.com/message/19893034#19893034



    and then as it didn't show hidden files...



    I did this:



    https://discussions.apple.com/thread/3828970?start=0&tstart=0



    Basically i installed OmniDiscSweeper which showed some of the files on the computer & then I ran it via the command file using the SuperUserDo (sudo) command which you can find here: http://www.macobserver.com/tmo/article/how_to_recover_missing_hard_drive_space/ **Use with EXTREME caution**



    Being the kind of gal that can't wait 5 mins for an answer to a problem & who always throws caution to the wind, I ran the sudo command & got a really strange error message...... OCCCrashCatcher: Not enabling crash catching since we're connected to a tty (and thus presumably in gdb) so i looked that up... and didn't really get anywhere (does anyone know what that error message means?



    Anyway, when I ran OmniDiscSweeper again it forund all 499GB of files on my computer including the ones the previous owner had deleted but not completely erased & I deleted them & I now have over 250GB free space & 2 new questions!



    1) how do i fix the settings on my trash can? At the moment it comes up as empty straight away when I put files in it, but I can't work out how to stop it doing that, so instead of deleting them, it seems to hide them meaning tat the computer fills up too quickly and



    2) what on earth does the error message above mean?
     

Share This Page