Macbook mouse/keyboard problems

Discussion in 'Mac Basics and Help' started by arvidvp, Apr 25, 2019.

  1. arvidvp macrumors newbie

    Joined:
    Apr 25, 2019
    #1
    Hi everyone,

    I was hoping someone here could help me with my problem: I have a macbook unibody white 2009 and it always worked fine. A few weeks a go the mousepad and keyboard started acting up. All of a sudden the keys on the keyboard (mainly the special keys, not the letters/numbers) didn't work anymore, but more annoying: the mousepad only gives "right clicks". It is not possible anymore to left click with the mouse. The strange thing is that when i restart the macbook everything works fine, but after a few minutes without doing anything in particular, the mouse only gives right-clicks, even when I left click... Working on the macbook becomes impossible...

    I tried connecting several different mouses, because I tought the problem was with the mousepad. However the external mouses also give the same problem. I checked the settings concerning mouseclicks but everything seemed fine...


    Could someone give me a hint as to what to do? Could it be a hardware problem?

    Thanks a lot!

    Arvid
     
  2. Mikael H macrumors 6502a

    Joined:
    Sep 3, 2014
    #2
    Check your battery for swelling. Weird things happen if it starts pushing against the bottom of the trackpad/keyboard.
     
  3. arvidvp thread starter macrumors newbie

    Joined:
    Apr 25, 2019
    #3
    Thank you for your reply. I opened up but couldn't notice anything strange about the battery. Also that would not explain that an external mouse doesn't work properly either I suppose?
     
  4. Mikael H macrumors 6502a

    Joined:
    Sep 3, 2014
    #4
    A stuck modifier key (cmd, option or shift) might.
     
  5. arvidvp thread starter macrumors newbie

    Joined:
    Apr 25, 2019
    #5

    So i opened up the macbook and saw it was really dirty inside. I cleaned it a bit with a dry cloth and very carefully with a vacuumcleaner. I removed the battery to check for swelling but there was none. I closed up and, well, the problem is gone...

    So it might have been dirty being stuck under the mousepad I assume? Strange thing is that the left cmd button still isn't working, but the right one is...
     

Share This Page

4 April 25, 2019