MacBook Newbie Question (Network)

Porscheboy16

macrumors member
Original poster
Aug 1, 2006
59
0
Hello, I just got my MacBook yesterday, and I only had an hour or so to test it out. I have one gripe, connecting to a network is very difficult with the MacBook (a lot more than my PC's). How do I get it to connect? I plug the ethernet cable into the Mac, but it won't auto connect like any of my PC's. With the PC's, you can plug it in, and it will auto-connect (even when it is the first time being plugged in). Thanks guys, I am at work, and I will try to solve this mystery when I get home.

Network:

-Comcast Cable
-No router, direct plug from modem.
 

kalisphoenix

macrumors 65816
Jul 26, 2005
1,231
1
That's very strange and it should not be happening. Open up System Preferences, click Network. There are two pop-up menus in the upper part of the menu -- click "Show" and "Network Port Configurations" and then make sure that "Built-In Ethernet" is the first in the list. Then click "Show" again and click "Built-In Ethernet" and make sure that, next to "Configure IPv4," that the pop-up menu is set to "Using DHCP."
 

Porscheboy16

macrumors member
Original poster
Aug 1, 2006
59
0
I keep on getting a 169 IP address, and it doesn't work. Could my MacBook be FUBAR'd? I just got it yesterday.
 

gekko513

macrumors 603
Oct 16, 2003
6,302
1
Those are the default settings. It should be plug and play. I did experience something similar a couple of times (getting that strange IP), and that was caused by a bad cable or poorly connected cable. Perhaps try a different cable and try to reseat the cable differently in case it has a bad fit.
 

Porscheboy16

macrumors member
Original poster
Aug 1, 2006
59
0
gekko513 said:
Those are the default settings. It should be plug and play. I did experience something similar a couple of times (getting that strange IP), and that was caused by a bad cable or poorly connected cable. Perhaps try a different cable and try to reseat the cable differently in case it has a bad fit.
Thanks will do.
 

gekko513

macrumors 603
Oct 16, 2003
6,302
1
That's strange. Have you changed any settings on the router? Try resetting the router to factory settings just in case (I believe most routers has a reset button that must be pressed for several seconds). If that doesn't work. Find somewhere else with an ethernet connection and try to plug in your MacBook to find out if you have a faulty ethernet port.

[resetting] Macintosh Users:

- Make sure the coaxial cable is plugged securely into the modem and the wall outlet (a loose connection could result in lost or slow connectivity)
- Unplug the cable modem from the power source
- Leave the modem unplugged for two minutes
- Shut down the computer and turn it off
- Plug the cable modem directly into the wall outlet
- Wait up to approximately five minutes for the modem to regain sync (it usually takes less the two minutes and for many people, it takes less than one minute to gain sync)
- Check the lights on your modem to insure the cable lights are steady
- If the lights are illuminated, try visiting various Web sites
- If your cable lights are properly illuminated but you cannot connect to Web sites, try release/renew and also restart your computer
 

Porscheboy16

macrumors member
Original poster
Aug 1, 2006
59
0
gekko513 said:
That's strange. Have you changed any settings on the router? Try resetting the router to factory settings just in case (I believe most routers has a reset button that must be pressed for several seconds). If that doesn't work. Find somewhere else with an ethernet connection and try to plug in your MacBook to find out if you have a faulty ethernet port.
I don't have a router. I don't know what to do, I am getting very mad because I want to enjoy the new Mac. Right now I am on my old Dell Inspiron:mad:
 

gekko513

macrumors 603
Oct 16, 2003
6,302
1
I edited my post above with troubleshooting steps from comcasts site. Have you tried those?
 

Porscheboy16

macrumors member
Original poster
Aug 1, 2006
59
0
gekko513 said:
I edited my post above with troubleshooting steps from comcasts site. Have you tried those?
Going to workout, I will try those when I get back, thanks!
 

Hobodale

macrumors member
Jun 4, 2006
39
0
I have had the same problems with my macbook. It wont auto connect with an ethernet cable. It connects wirelessly just fine. Its wierd necause its the only experience I have had with a mac so far where its not plug and play.
 

MikeNemat

macrumors regular
Aug 6, 2006
155
3
Porscheboy16 said:
I keep on getting a 169 IP address, and it doesn't work. Could my MacBook be FUBAR'd? I just got it yesterday.
That has nothing to do with your macbook at all. The network/device you are connecting to is not sending out DHCP data for your macbook to receive an IP address.

DHCP is a cross-platform spec. It will work on any device that supports it, be it mac, windows, linux, windows mobile, basically almost all IP-enabled devices.

If you are connecting directly to a modem, beware. Your ISP may be restricting MAC addresses, turn off the modem for 20 minutes and disconnect the power and then try again.
 

xwingsct

macrumors member
Aug 13, 2006
30
0
I have no problem connecting my Macbook with either my wireless Netgear router or direct connect with with ethernet port at all. But I do have problem connecting with my Brother's Usrobotics router though. I eventually got it to connect a different method which mac guide me through when I could't connect. I wonder if the maker of the router has anything to do with it. But I do have one other problem though.
USrobotics router has a printer port built-in with the PC laptop I can print anything wirelessly to the printer. I just can't get it to work with Mac. I don't know why.
Gotta play with it around some more.
 

SJR

macrumors newbie
Nov 29, 2007
4
0
Nottingham, UK
Does anyone have an actual solution for this widely reported problem (other than buying a new router etc.)?

I have just bought a brand new MacBook Pro, running Leopard and I just cannot get it to connect to the wireless access point at my workplace although I do not have any problems connecting to wireless networks at home. Same problem as reported many times on many Mac forums... connects to router or access point just fine, but will not obtain an IP address.

Changing the access point or its configuration is out of the question for me as this is under the control of my customers IT Department and their attitude is "... well it's your fault for buying a MacBook!!!" (idiots)

I have been into the local Apple store and seen the guy at the genius bar but he could not suggest a solution!

For reference, my old PeeCee, my Nokia N95, my iPod Touch AND my MacBook Pro (booted into Windoze XP via Boot Camp partition) ALL connect to the router without any problems whatsoever, so it is not MacBook hardware related...

It has to be a bug in Mac OSX... doesn't it?!? :confused:

Can anybody please help? Thank you.