Macbook No Bootable device

Discussion in 'MacBook' started by Farrgo, Nov 25, 2010.

  1. Farrgo macrumors newbie

    Farrgo

    Joined:
    Nov 25, 2010
    #1
    I recently booted my mac book to a Knoipix cd to show off to some friends how capable the macintosh hardware is. But now when I try to boot it back to Mac OS, it gives me a "No Bootable device -- insert boot disk and press any key" error.

    The logical response would be to Option boot it, as par the answer i found here, but it's a company machine, not my own, so there is a firmware password on it which I can not unlock.

    I've tried resting the PRAM, but it has never worked. It's a late 2009 white plastic uni-body macbook.

    Any way around this?
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    Do you mean knoppix? a Linux CD? Sounds like the Linux OS wrote something on the osx disk and munged it.

    If you were able to boot a Linux CD, why can;t you just boot the OSx DVD?
     
  3. Farrgo thread starter macrumors newbie

    Farrgo

    Joined:
    Nov 25, 2010
    #3
    Because it's a company machine, I don't have the disks.

    And yea, I just failed at spelling Knoppix in the OP.
    Knoppix won't even mount the HDD unless you tell it to, which I didn't so there's no way it could have messed with the boot table or anything like that.
     

Share This Page