Macbook no longer automatically connects to upgraded router.

Discussion in 'macOS' started by richimages, Dec 27, 2012.

  1. richimages macrumors regular

    richimages

    Joined:
    Mar 20, 2008
    Location:
    Southeastern US
    #1
    I upgraded my very old LinkSys router with a new one that is much faster, and better.

    I kept the same SSID and Password.

    Now, my Macbook will no longer automatically connect to the wifi - it reports that there are no "Previously Known WiFi SSIDs".

    It list my new Router's same old SSID in the list ... and it remembers the password ( I don't have to type in the password to make a connection ) ...

    But I have to select the SSID manually by clicking on it from the list - EVERYTIME I OPEN MY MACBOOK!! **annoying**

    I have tried to delete the router, and re-enter it manually ... but it still sees this router as a "new one" - never before used - (eventhough it know's the passord to use to make the connection. )

    Anything else I should try? Ideas??

    Thanks,
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Go to this screen in the Network pane of System Prefs and make this box is UNchecked.

    [​IMG]

    Now go the advanced tab in that same panel and make sure this box IS checked. Also select each network shown under preferred and click the minus to remove all networks listed there.

    [​IMG]

    Now restart the machine and manually select the SSID and enter your password. That should create a new entry in the above panel that is remembered across restarts.
     

Share This Page