MacBook No Wireless Connection to the Internet Despite Showing Full Connection

Discussion in 'MacBook' started by imaladyimnotama, Oct 28, 2010.

  1. imaladyimnotama macrumors newbie

    Joined:
    Oct 28, 2010
    #1
    Hi, I'll keep this as brief as possible.

    Background: got a nasty virus as I installed what I thought to be a genuine copy of Photoshop from Pirate Bay :p. The technician reinstalled the whole system (and deleted all my pics in the process!).

    Now: I have attempted to copy my boyfriend's copy of Photoshop on my computer while the airport was on, unfortunately it didn't work as it said it had expired. I turned the airport off and tried again. Nothing, so I gave up and tried to turn the airport on again. Nothing.


    The computer had a self-assigned IP address. I managed to change the IP address and put it in manually, and do the same with the router and subnet mask.

    It now shows a green light, full connection and it has the right IP address and subnet mask, but it only connects via the ethernet cable. If I try to load a page the blue bar only comes up to the first two 'ws' of any given address, then I get a Safari page that says that I can't connect to the internet. I have spoken to the broadband guys and checked the settings with them, it's all fine. Plus my flatmates can both connect (both with Macs, no problem).


    Has Photoshop anything to do with it or was it just a coincidence?

    And, mainly, what the heck can I do to go wireless?

    And, no, no more Photoshop for me, no worries!;)

    Thanks to anyone that can help!

    V
     
  2. imaladyimnotama thread starter macrumors newbie

    Joined:
    Oct 28, 2010
    #2
    Sorted!

    Should anyone else have the same problem, here's how I've sorted it out.

    Network-Location (add a new location from the drop down menu)-Insert your network name, add the password and the default airport settings should be restored).

    Good luck
     

Share This Page