MacBook not accepting charge?

Discussion in 'MacBook' started by ColdnessAwaits, Dec 15, 2010.

  1. ColdnessAwaits macrumors newbie

    Joined:
    Dec 15, 2010
    #1
    When we plug this MacBook in, the light on the magsafe turns orange for about 10 seconds, then turns green; therefore not charging the battery. We switched the battery out with another one, but the magsafe LED shows the same results. We then decided to use a different magsafe, but it still does the same as before; turn orange, then quickly turn green again. Does anybody know what could be wrong?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
  3. dconnhssl macrumors newbie

    Joined:
    Dec 13, 2010
    #3
    I have a similar problem (not resolved I'm afraid) but you can try a PRAM reset - it had an effect on my macbook (made the magsafe go to oracle but this didn't last more than 10 seconds I think)

    power off your macbook. Power on while holding down "command", "option", "P" and "R". You should hear a quiet apple start chime and then, maybe 5 seconds later, a louder chime. Then let go of the keys, let the notebook boot, and see if it makes any different

    Good luck - I suspect, in my case, that my logic board is the problem

    Derek
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    PRAM has nothing whatsoever to do with batteries, power or charging. Read the link I posted.
     
  5. dconnhssl macrumors newbie

    Joined:
    Dec 13, 2010
    #5
    Hi GGJstudios,

    I concede that you are absolutely correct and my advice was entirely wrong (PRAM: http://support.apple.com/kb/ht1379).

    It was still very strange that after I reset the PRAM, booted up, and connected my PSU that the orange LED on the magsafe adapter lit perfectly after momentarily showing bright green. It returned to my broken dim green state afterwards but I may have messed with the power cable (not sure now and I can't reproduce). I haven't seen a bright green or orange led on the magsafe PSU in 6 months on this macbook. To me this is a very strange coinsidence.

    Derek
     

Share This Page