MacBook Not Connecting to Airport

Discussion in 'MacBook' started by FutureSailors, Jun 23, 2010.

  1. FutureSailors macrumors newbie

    Joined:
    Jun 23, 2010
    #1
    Hey mates,

    Here's the deal:

    I have a wireless router at home. It is not WEP protected. A few months ago, I could connect to it with no problems at all.

    Last month, I connected to my schools wireless router. I have a username and a password that I use to connect to this 802.1X WPA-protected airport.

    Ever since I first connected to my school wireless, I can no longer connect to my home wireless. My MacBook recognizes the router, but when I try to join it loads for a few seconds then times out. I've tried connecting every day for a few weeks, but to no success.

    Any help would be greatly appreciated.
     
  2. andalusia macrumors 68030

    andalusia

    Joined:
    Apr 10, 2009
    Location:
    Manchester, UK
    #2
    Go to network preferences, select Airport in the left sidebar, click on Advanced..., and drag your home network to the top of the list if it isn't already there. See if that helps at all.
     
  3. FutureSailors thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    #3
    Unfortunately that didn't help. It still tries to connect to the airport, then times out.

    If this helps:

    My computer crashed a while back, and I got the hard drive replaced. When I came back home I was able to connect to my home wireless without a problem. Again, once I connected to my school wireless I was unable to connect to my home wireless.

    Based on this, I'm sure it's not an interference/hardware problem. I can connect to my home wireless with my PS3 and iPod Touch fine. I fear that it's something in the settings that's preventing my Macbook from connecting.
     
  4. GidbinN macrumors member

    GidbinN

    Joined:
    Dec 25, 2009
    Location:
    Northrend
    #4
    It might be a proxy thing,

    if you're using safari (because Firefox use its own proxy)

    Go to Apple Logo->System Preferences->Network->AirPort

    Select the correct Network name and retype the password.


    I hope that works, if not, good luck.
     
  5. FutureSailors thread starter macrumors newbie

    Joined:
    Jun 23, 2010

Share This Page