Macbook not recognizing isight?

Discussion in 'MacBook' started by tigress666, Oct 27, 2010.

  1. tigress666 macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
    #1
    Ok, so I tried to get my parents to use facetime on their new macbook they bought in February this year. They've never used the isight before. I'm not actually in the same state so all I know is what my dad tells me.

    Facetime gave the error of it needing a supported camera to use (even my MBP just gives me a camera off error when my MBP is closed and connected to an external screen but still recognizes it has a valid camera).

    Even photobooth gives them this error.

    Ok, sounds simply like their computer doesn't recognize the isight connected for whatever reason (broken, connection not there).

    But he took it to the Apple genius's and he says it worked perfectly fine there and the genius got facetime running fine and he was looking at himself on his computer. But when we tried again it gave him the same error.

    So any suggestions (are there ways my dad could be doing something wrong to cause the macbook not to recognize the camera)? My dad insists it must be the wifi at the house (he used to be better about technology, I can't convince him that it wouldn't be that.. unless I'm wrong? But I really don't see how wifi would have anything to do with the macbook recognizing its internal camera).
     
  2. tigress666 thread starter macrumors 68040

    Joined:
    Apr 14, 2010
    Location:
    Washington State
  3. lucky° macrumors newbie

    Joined:
    Oct 31, 2010
    #3
    I know this is late and may not be any help to you but I had this problem with a MacBook Pro.

    PhotoBooth, iMovie, iChat.. nothing recognized my iSight camera. I took it to the Apple Store. They told me it was an issue with the graphics card which, for some reason, stopped supporting Quartz Extreme. Replacing the logic board solved the problem.

    I really have no idea what is causing the problem for your parents' MacBook. Perhaps your father is doing something wrong.

    Check this out. As one of the solutions says, try to get your father to use iSight in another user account.

    Also, many other people said that resetting SMC solved the problem for them. The link above also tells you how to do that with "portable computers that have a battery you should not remove on your own" - your unibody MacBook, in this case. Try that, maybe it will help.

    Sorry and hope you get it resolved. :eek:
     

Share This Page