Macbook not Recognizing Scanner on Canon Pixma MP480

Discussion in 'Mac Accessories' started by luvmymacbook, Mar 4, 2011.

  1. luvmymacbook macrumors newbie

    Mar 4, 2011
    Hi all,

    I have a Canon Pixma MP480 and no matter what I do, I cannot get my Macbook to recognize it. I have found a couple of other people with the same problem online, and they were told to download the appropriate driver from Canon.

    I have done this, but still cannot for the life of me get my MB to scan. The printing works just fine, but no luck on scanning.

    Any tips?
  2. Aidoneus macrumors 6502

    Aug 3, 2009
    Is the printer attached via USB, or shared over a network?

    With my MP240, my Mac would not recognise the scanner unless it was directly attached via USB.
  3. iamvexed macrumors member

    May 27, 2008
    What exactly have you tried?

    For instance, have you tried opening Preview, going to File-->Import from Scanner?
  4. luvmymacbook thread starter macrumors newbie

    Mar 4, 2011
    I have it hooked up via USB, and the printer works fine, just not the scanner.

    I tried reinstalling the drivers, and the Genius Bar tried finding the scanner on the devices page, and tried going to preview and importing from scanner.

    I'm going to call Canon when I get a chance since Genius Bar couldn't figure it out. Thanks for your tips, if you have any more that would be helpful. I'll keep you posted on what Canon says.
  5. pallance macrumors newbie

    Sep 26, 2012

    Hey luvmymacbook, I've got exactly the same problem with exactly the same printer on a brand new MBA with Mountain Lion 10.8.2. Installed and reinstalled all drivers multiple times...scanner recognized by my old MBP but not the new MBA...

    Did you ever find a solution?

Share This Page