Macbook not seeing Flashdrives?

Discussion in 'Mac Basics and Help' started by dragon2611, Jul 3, 2008.

  1. dragon2611 macrumors regular

    Joined:
    Sep 19, 2004
    #1
    Got a 1.83ghz coreduo macbook with 2gb ram 120gb hard-disk running Lepoard

    Went to copy a file onto a USB flashdrive earlier only to find it didn't mount the flashdrive.

    The drive was an 8gb sandisk crusier that I think is formatted as fat32.

    So then I tried a 2gb sandisk crusier and a 1Gb Kingston flashdrive, again the same.

    I'm 99.9% sure that these drives are all fat32 formatted and they were formatted to somethign the Mac couldn't read i'd expect them to show up in disc utility?

    The only place They did show up is if I look under USB in system profiler it does Show the device as connected and correctly displays information about the drive (power usage, Manufacturer, revision.etc)
     
  2. techound1 macrumors 68000

    techound1

    Joined:
    Mar 3, 2006
    #2
    Dang, the last sentance mucked up my diagnosis of dead port. :rolleyes:

    Have you rebooted?
     
  3. dragon2611 thread starter macrumors regular

    Joined:
    Sep 19, 2004
    #3
    Yep tried that.

    Will try something else in the USB ports later to make sure they're not dead. I really hope they're not because I use them fairly regularly.


    Edit:

    Well tried a USB modem (E220) and a USB Mouse

    The mouse worked but the modem (even when connected to both ports) failed to work correctly, it powers up but Launch2net cant find it.
     
  4. dragon2611 thread starter macrumors regular

    Joined:
    Sep 19, 2004
    #4
    Well not sure what the problem was, other than it Must have been Software and not Hardware.

    Popped the OSX DVD in and Did an "Archive and install" and selected the option to keep my existing user accounts/network settings

    That seemed to fix the problem.

    Also Updated to latest release via software update, and USB is still working.

    Best guess is something to do with how OSX sees USB devices must have got corrupted.
     

Share This Page