Macbook note restarting after software updates!

Discussion in 'MacBook' started by szachary11, Oct 5, 2009.

  1. szachary11 macrumors newbie

    Joined:
    Oct 5, 2009
    #1
    So yesterday I updated a bunch of programs on my macbook via the autoupdate function. Some of the programs I updated required a restart...which I performed when it prompted me to. Now my macbook won't restart all the way. It turns on and gives the chime then goes to a gray screen with an apple on it. After about a minute a spiral loading image appears underneath the apple and about a minute after that the computer shuts off and immediately restarts again only to do the same thing (its stuck in some sort of cycle). If anybody knows what this problem is please let me know what I can do to fix it. I've tried resetting the PRAM and a few other things but nothing seems to work. Thanks in advance for your help!
     
  2. danielfishr macrumors newbie

    Joined:
    Oct 5, 2009
    #2
  3. agentcircus macrumors newbie

    Joined:
    Sep 30, 2009
    #3
    Your problem is most likely a failed software update, however there may be a chance that it's the hard drive. Did you recently install a 10.5.7 or 10.5.8 update? If the answer to that question is yes, you need to reapply the update. If you can't perform the following steps yourself, take your Mac to the Genius Bar and see if they'll do it for you:

    1. Boot from an external drive with a known good OS or put your Mac in target disk mode and connect it to another Mac.
    2. On the known good OS or the other Mac, download the 10.5.8 update from apple.com/support/downloads
    3. Open the update and apply it to your Mac's internal hard drive

    If that doesn't work, back up your data and perform an archive and install or an erase and install (erase is usually not necessary, but some people prefer that method as it is cleaner - you will have to reinstall all of your apps and transfer your data back though). If that fails and you do need a new hard drive, use this as a chance to upgrade it. The same thing happened to me and I got a new 320GB drive with Snow Leopard preinstalled from http://www.macbookupgrades.com
     
  4. kittywittyditty macrumors newbie

    Joined:
    May 6, 2012
    #4
    Had the same problem on a macbook. fixed it :)

    I tried installing snow leapord, I hit restart, and it got into a reboot cycle, so I used one of the old tricks... +Option+P+R. that resets the perimeter ram, worked for me! and I got the software update!:):):):D:D
     

Share This Page