Macbook OS installation

Discussion in 'MacBook Air' started by zerth, Mar 31, 2015.

  1. zerth macrumors newbie

    Joined:
    Dec 19, 2014
    #1
    Hi,

    I have the same problem I had with my Macbook I had in 2008.

    Now the problem is with my new macbook air from 2013.

    The magsafe connecter doesn't work properly, battery doesn't charge, and so on... I had this problem before and I know it's not a battery problem...

    Anyways I tried everything to solve the problem until I tried the last option, erasing all data (backing up important files on an external disk.) Right now. I try to reinstall the original OS that came with the macbook (I guess it should be Mavericks. Now it's been 3 hours I am stuck on this page!).

    It get's me crazy, now I can't even access my mac os?! I can't reinstall anything, this is madness?

    Does anyone know how I could solve it? My wifi connection works perfectly and the code is exact (tried it many different times), it just stays stuck!!!!

    The photo isn't very clear but it shows a internet provider and a password entered and my macbook just waiting waiting and waiting to connect....
     
  2. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    Same weird problem happening to you twice, that gotta be YOU.
     
  3. zerth thread starter macrumors newbie

    Joined:
    Dec 19, 2014
    #3
    Probably , yes. It probably has something to do with the way I use my MacBook, no idea what it would be. I take care of my macbook.

    This is my 3d macbook (my 2nd macbook air and it happened with 2 of those MacBooks).

    Nevertheless, I did some research on the internet and I found out I'm not the only one with this problem. So it's not THAT uncommon.

    I'm now reinstalling Mountain Lion (it finally worked by connecting to a wifi connection that didn't require a password, very weird that this doesn't work with a wifi connection that required a password).

    Anyways, I'm very sceptical about the outcome since I think it's a hardware problem and not a software problem (it didn't work out with my 2008 macbook either). The only thing I can do is trying.
     
  4. Airboy1466 macrumors regular

    Airboy1466

    Joined:
    Feb 23, 2015
    #4
    Im having a similar problem with my 2015 I’m sending it in for repair have you tried doing the apple hardware test shut down system press power button then immediately hold down the D key until you see spinning globe follow on screen instructions after that
     

Share This Page