Macbook OS X Mavericks Wifi Disabled (Can't seem to turn it on)

Discussion in 'MacBook' started by Yuurei, Mar 24, 2017.

  1. Yuurei macrumors newbie

    Joined:
    May 2, 2016
    #1
    I just received a new mid 2010 macbook in today and I started to set it up, but I wasn't able to connect to my wifi when first setting it up. I skipped the internet connection part but now I can't find anyway to connect to my wifi. There isn't a wifi icon on my status bar either. Many thanks for the help.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Hmm, that doesn't sound too promising. I'd start by chancing an SMC/PRAM reset and see if that makes a positive difference.

    You can also check System Information (Apple menu, hold Alt, 'About this Mac' will change), then see if Wi-Fi shows any detected hardware under Network.
     
  3. Yuurei thread starter macrumors newbie

    Joined:
    May 2, 2016
    #3
    I've tried both of those and I don't think they worked.

    This is all under the System Report > Network > Wifi

    What I have is:

    CoreWLAN: 4.3.3 (433.48) CoreWLANKit 3.3.2 (332.36) Menu Extra: 9.3.2 (932.35) System Information: 9.0 (900.8) IO80211 Family: 6.4 (640.36) Diagnostics: 3.0 (300.40) AirPort Utility: 6.3.2 (632.3)
     
  4. Aston441 macrumors 6502a

    Joined:
    Sep 16, 2014
    #4
    Buy a $5 USB wifi dongle from Amazon so you can download software to troubleshoot, and to make it work until you can figure out how to fix the internal radio.
     

Share This Page