Macbook overheats. Fans LOUD!

Discussion in 'MacBook' started by bjones521, Oct 12, 2009.

  1. bjones521 macrumors regular

    Joined:
    Jul 22, 2009
    #1
    Ever since I downloaded Snow leopard my fans are always on and the bottom of my unibody macbook is always hot. Anyone have a solution for this?? Thank you!
     
  2. eman macrumors 6502a

    Joined:
    Nov 5, 2007
    Location:
    In the great white north
    #2
    Look at the top right hand corner of the desktop at the magnifying glass, does it have a dot in the center that is pulsating?
     
  3. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #3
    Beyond looking for Spotlight activity (which wouldn't be abnormal given the update) you can go to Activity Monitor (Applications-->Utilities) and change the drop down from "My Processes" to "All Processes" and see if something has hung and is eating up CPU cycles.

    If it's not a system process (like Spotlight) you should be able to stop the process and watch your computer start to cool down pretty quickly.
     
  4. bjones521 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    #4

    No it doesn't. What would that mean?
     
  5. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #5
    Spotlight is indexing is what that means. I would recommend trying a PRAM and SMC reset and see if that helps cool things down.
     
  6. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #6
    Taking bets on the Flash plugin and more aggressive fan settings under Snow Leopard.
     
  7. bjones521 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    #7

    And how do you do this???
     
  8. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #8
  9. prodigee macrumors 6502a

    Joined:
    Sep 23, 2009
    Location:
    Brooklyn, NY
    #9
    Google it. They are both reset by key strokes if I do remember correctly.
     
  10. pcs are junk macrumors 65816

    Joined:
    Sep 28, 2009
    #10
    ok i know how to fix your problem. go to google and search "smc fan control download" download that, run it, it should appear on ur menubar at the top that should say __˚F
    __rpm
    click on this, click preferences, then drag the blue ball all the way to the left, then hit save. this should make your computer sound much smoother, and u wont hear a thing. good luck! =)
     
  11. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #11
    That's not a fix....if his computer is overheating/running hot the absolute LAST thing you want to do is force the fans to run at a speed not spec'd by the OS!! :mad::mad:
     
  12. bjones521 thread starter macrumors regular

    Joined:
    Jul 22, 2009
    #12
    yea nothing seems to work. Should i take my computer back to apple?
     
  13. jbuk macrumors regular

    Joined:
    Jun 8, 2009
    #13
    Open up Activity Monitor (in Applications > Utilities) and in the drop-down on the right hand side of the toolbar, change to 'All Processes'. Sort the list by CPU use, and see if there is a process that is using a sizeable chunk of CPU time.
     
  14. eshroom macrumors 6502

    Joined:
    Oct 18, 2006
    #14
    I've got a white 2Ghz C2D and when I surf the net and have mercury open fans hover between 3500-4000. I've done everything mentioned so far in this thread, no noticeable difference.
    Is this normal, or should I send it to apple before the 3 year warranty expires in 3 weeks?
     
  15. NewMacbookPlz macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #15
    Does surfing have a lot of Flash video or Flash apps in it in your case? If yes, then it's Flash being a resource hog and yeah....nothing to do really.
     
  16. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #16
    I reckon its being caused by one of the following:

    1. Some sort of system activity (spotlight indexing, for example).
    2. Flash videos or flash games.
    3. The fans set to run faster on Snow Leopard on your MacBook model.

    The first reason will go away by itself, the second reason can be solved by avoiding flash on your Mac (http://factoidz.com/alternatives-to-using-flash-on-your-mac/). And I'm not sure what to do if its the third reason...
     

Share This Page