Macbook Pro 13"; - A1278 - No Power from Any Source

Discussion in 'MacBook Pro' started by maxtmon, Dec 12, 2012.

  1. maxtmon macrumors newbie

    Joined:
    Dec 5, 2012
    #1
    Macbook Pro 13" - A1278 Mid 2010 - Ser#ATP

    I've read the previous post here in forum regarding MBP not powering on. In addition, several other forums, blogs, and MBP sites.

    I've ran through the basic "fixes", reset PRAM, SMC, "jump starting; ( http://www.scribd.com/doc/84466742/...-2010]http://www.scribd.com/doc/84466742/39/L ... s-Mid-2010 ), and powering with and without battery in combination with the above attempts. Also, I have disconnected different components, one at a time and in-conjunction with others.

    What i know at this point:
    1. No power, no clicks, no whirls
    2. Unkown if any liquid spill history; however, there are some signs of corrosion around the screws and copper on MB.
    3. Magsafe is brand new OEM 85W, and works with other MBP.
    4. MagSafe light stays green at all times, even with battery in or out.
    5. No burnt smell or indications on bottom of MB. I have not pulled it completely out yet to check top side of MB.
    6. Once I pull the MB out, I will give it an iso bath, scrub, and rinse.

    Any other tips or tricks?

    Thanks Max
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    I'd say take it to apple for repair.
     
  3. maxtmon thread starter macrumors newbie

    Joined:
    Dec 5, 2012
    #3
    I may, eventually just to see what they diagnose. But one, its out of warranty, and two, I live 300 miles from the closest Apple Store. But before I tear into it to far, I just may make an appointment (stupid that has to be done), as we are going to the city after Christmas. Thanks for the idea.
     

Share This Page