MacBook Pro 13" Airport issue

Discussion in 'MacBook Pro' started by gercas, Mar 24, 2013.

  1. gercas macrumors newbie

    Joined:
    Mar 24, 2013
    #1
    Hi all,

    Ive done some searching but cant seem to get any advice.

    I had some intermittent issues with my wifi. It would work for 10/15 mins then stop functioning. Restarting the computer would rectify but occasionally it would say "no hardware installed"

    I brought into apple, still in warranty and they said they would replace the airport. Get a phone call to say liquid damage, argh!

    Anyway, about 8months ago I spilled a small amount of coffee on the keyboard. I thought I had got away with it! Anyway, apple are completely within their rights to refuse warranty.

    The thing is, the area that the coffee hit, is around 3 drops and is nowhere near the airport card. Not to mention I had zero issues over the 8month period. I have since cleaned it up.

    I kind of think that the coffee didnt damage the wifi. I have checked all the connectors etc, as I still think it must be shorting itself(which explains why restarting solves the prob for a period).

    Anyone any ideas? Alternatively, can you guide me towards a wifi dongle that would work well? I cant find many that are mac compatible. My macbook is from late 2011 and 13"

    thank you! Im a poor student and cant bare to tell my parents Ive damaged my mac, hoping for a simple solution! As nothing else has been wrong for 8 months bar this new wifi issue....
     
  2. irishelysia923 macrumors newbie

    Joined:
    Apr 20, 2013
    #2
    Same problem here! well no liquid damage but basically keeps saying no airport card installed :( i just posted a new thread didn't see yours. if I have any luck I'll let you konw. Did you try resetting the PRAM and all that? Some people had luck w/ that. And massaging the black piece behind the keyboard. Good luck let me know if you figure anything out.
     

Share This Page