Macbook Pro 13 detects wifi but will not join

Discussion in 'MacBook Pro' started by DangerousDave2k, Aug 19, 2016.

  1. DangerousDave2k macrumors member

    Joined:
    Jul 11, 2014
    #1
    Hi all,

    I have a late 2011 Macbook Pro 13, which is unable to join my wifi network despite detecting it with good signal strength. It reports the error "The wifi network (Name) could not be joined".

    It seems to join the wifi network alright when I start up and use the option key (so, outside of the OS, I suppose).

    I am using El Capitan.

    Can anyone advise on what the problem might be?

    Thanks in advance.
     
  2. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #2
  3. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Yep, advice above is great. If that doesn't work, you can try reset the PRAM by holding CMD + ALT + P + R as soon as you turn your Mac on. Continue holding those four keys until you hear the Apple boot chime 3 times, then let go.

    You can also try plugin via Ethernet and check for OS updates. The current version is 10.11.6.

    For troubleshooting purposes, it may also be worth creating a new administrator user account to see if it works through there.
     
  4. DangerousDave2k thread starter macrumors member

    Joined:
    Jul 11, 2014
    #4
    Thanks for replies. When I went to the Network page, it didn't seem be trying to connect to a network, so could not tell it to forget. I tried the procedure in the link, but it didn't go exactly as described (one of the four files was not present in the folder anyway - could this be a problem? It's the one called com.apple.network.identification.plist). I tried deleting them and restarting, but the wifi was already on again when it restarted, and the procedure did not enable the machine to join the network.

    I've tried resetting the PRAM but that didn't work.
     

Share This Page