Macbook Pro 13 early 2011 "no batteries detected"

Discussion in 'MacBook Pro' started by hemmjonny, Dec 5, 2014.

  1. hemmjonny macrumors newbie

    Joined:
    Nov 11, 2011
    #1
    Hi guys,

    I hope someone can help. I have an early 2011 Macbook Pro 13 it was working OK but now has come up no batteries detected and I have tried a pram reset, smc reset and a new battery but still no luck.

    I did manage to get it to work for a while by turning it on with the power adapter connect then restarting it but at the point of the restart I pulled the power and it came on with the battery.

    If I start it with the power adapter connected and then pull the power it will boot to the login screen briefly then go into sleep until I reconnect the power.

    I am out of ideas and I am ment to be giving it as a present to my girlfriend at Christmas :-(

    When the power adapter is connected it just has a solid green light at all times never changes even if I do the smc reset.

    I really hope this can be repaired if anyone has any ideas it would be very much appreciated.

    Thanks in advance

    Jonathan
     
  2. jdphoto macrumors 6502

    jdphoto

    Joined:
    Jan 13, 2014
    #2
    If you've already replaced the battery it may be a board issue. I've actually never seen a "no batteries detected" message. Since it's a new battery (and presumably a new connection cable) it may be the socket where it connects to board. I'd recommend taking it to get serviced at your nearest Apple Certified Repair Center.
     
  3. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    Sounds like you may have a bad battery. Work on getting another replacement.
     
  4. hemmjonny thread starter macrumors newbie

    Joined:
    Nov 11, 2011
    #4
    Thanks for the replys. I cannot see anything obvious on the board. The battery was tested before I put it into my mac. I really hope it's not the logic board but I guess it's looking likely :-(.

    I think like you said I may need to take it into apple. Do you know if they charge for diagnostics?

    Or has anyone else got any ideas how I can repair this problem.

    Thanks again
    Jonathan
     
  5. hemmjonny thread starter macrumors newbie

    Joined:
    Nov 11, 2011
    #5
    Logic board :-( over £300 to repair. Not worth doing
     
  6. l.a.rossmann macrumors 65816

    l.a.rossmann

    Joined:
    May 15, 2009
    Location:
    Brooklyn
    #6
    is there an X on the battery or does it just say it is not charging? X on the battery is usually bad pullup resistor R5280/R5281 or bad SMC U4900. Measure signal end of R5280/R5281 to see what's up.
     

Share This Page