MacBook Pro (13-inch, Mid 2010) VERY VERY VERY Slow

Discussion in 'MacBook Pro' started by jmkalfut, Jun 15, 2014.

  1. jmkalfut macrumors newbie

    Joined:
    Jun 15, 2014
    #1
    Hi Folks,

    First, let me start to say I am an IT Professional by trade and know a thing or two about fixing PC/Macs, but this one is stumping me. A friend has a 13-inch Mid 2010 MacBook Pro that started to run very very very slow. I figured it was just a bad mechanical drive and figured swapping it out with a new SSD would be the fix. Well, that didn't work and I couldn't even partition the new drive. I figured maybe I had a DOA drive, so I connected the new drive via a SATA to USB adapter to another Mac and a PC and it runs great. I researched the error I got during formating and it was recommended to replace the SATA flex cable. The part took about a week to arrive, so the battery fully died. I couldn't get the Mac wouldn't power up after replacing the SATA cable and I didn't get a charge light either. I figured OK, maybe I have a bad power cord, so I tried another and didn't work either. I can only get it to power up with a 85w charger, but it doesn't seem the battery is charing either. OK, so we have power but it's acting weird... and now I could format the drive. Thought that was it and I could call this one done. I thought the install was running very slow (maybe 15 minutes to preload all the setup files) but I still let the setup routine run over night. Woke up the next day and the setup was still running! I am running out of ideas what is going on with this MacBook Pro. Any ideas??
     
  2. Cloudsurfer macrumors 65816

    Cloudsurfer

    Joined:
    Apr 12, 2007
    Location:
    Netherlands
    #2
    You said you swapped the HDD with an SSD. Did you perform a fresh install or did you clone the drive?

    If something in the original installation is causing the Mac to run slow it will also make the Mac run slow on the SSD.
     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    If it isn't seeing a battery it will throttle down as the mains charger cannot provide enough grunt for full operation. That might be one issue you have.

    Battery dying in a week - if it was fully charged at the start that further indicates a battery issue.

    Possibly you also then had a drive issue. On a throttled machine that might take a long time, then you also have spotlight to reindex which might take forever on a throttled machine.

    I think you need to fix the battery issue and see what it behaves like then.
     
  4. jmkalfut thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #4
    Fresh install, multiple times. The install takes about 30 minutes to load and then when it starts the GUI, it is very laggy (even the mouse movements). If I start the install, the fans kick up to 100% and the thing installs literally for about 20 hours. The system boots after the install, its just so so so so slow. I've tested the SSD via USB adapter and it is speedy as expected for file copies and reads.

    ----------

    If I fully disconnect the battery (at the board), shouldn't it run at full speed? The battery was low, but not depleted (was replaced maybe 12 months ago). Drive is brand new and works just fine via a USB adapter on another box for reads and writes. Spotlight shouldn't be indexing during install, correct? This is super super slow even during the OS X setup process.
     
  5. GhettoMrBob macrumors regular

    Joined:
    May 21, 2014
    #5
    As simonsi said, if that battery is either dead or disconnected it will severely throttle the CPU. It WILL run incredibly slow and sluggish. I recently had a client machine (dual core i7 13" MBP, 1TB SSD) with a dead battery and trying to even use it to get some work done before the new battery arrived was a joke.

    Try swapping in a known good battery or replacing it and I'm willing to bet those issues will go away.
     
  6. jmkalfut thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #6
    Hmm... interesting. Any ideas of where I can get a battery for this unit (OEM, not third party) and have the ability to return it if that is not the fix? I'd hate to spend $120 or so and it not fix the issue on an already old Mac.
     
  7. jmkalfut thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #8
    Yep, doesn't seem to make a difference. I've tried both methods (for newer and older MacBooks).
     
  8. jmkalfut thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #9
    Battery ordered... we'll see if this is the fix. Should be here by Friday.
     
  9. meson macrumors regular

    Joined:
    Apr 29, 2014
    #10
    Have you checked the fans to see if they need cleaned? Possibly in need of thermal paste?

    My white macbook had a few issues before it met a death from a liquid spill. In regard to the battery being out of the system, it would throttle the CPU, but not cripple the machine to the extent you are experiencing.

    I'm also pretty sure it was in need of thermal paste, as anything that would stress the processor above idle would ramp up the fans to full speed and begin throttling, again a significant effect, but not something that rendered it essentially unusable. I used it for the better part of a couple years that way, as I didn't feel comfortable doing that work on my primary machine that I really couldn't afford to replace.

    Hopefully you get your buddy's machine up and running again.
     
  10. AppleGoat macrumors 6502a

    Joined:
    Oct 14, 2010
    #11
    My friend has a similar issue with his 2011 17". It befuddled me. My recommendation was to get an SSD w/ a fresh install of OS X; I'm an SSD evangelist so it's my answer to just about anything but perhaps it wouldn't do his machine any good. Strangely, he has Mavericks on his machine but the wallpaper (which he has never changed in the life of the computer) is the default Snow Leopard nebula-ish one.

    Curious to see what the outcome is here.
     
  11. jmkalfut thread starter macrumors newbie

    Joined:
    Jun 15, 2014
    #12
    Fans are clean (blew them out with compressed air and not much dust came out, they do spin freely). Didn't check to see if it needed thermal paste, figured if I ripped it off I'd need to reapply. I suppose that is something I can try next, if the battery does not fix it.

    I've read that is makes it run at 50% CPU (maybe a single core?), so maybe that really would cripple it?

    I think there is a weird power issue going on, since it won't charge or run without the 85w adapter... so who knows, maybe it is the battery?
     

Share This Page