MacBook Pro 13 Late 2011 hard drive issue or not?

Discussion in 'MacBook Pro' started by robbiebnz, Jun 4, 2018.

  1. robbiebnz macrumors newbie

    Joined:
    Jun 3, 2018
    #1
    Howdy, I have a MacBook Pro 13 Late 2011 model A1278 running El Capitan OSX 10.11 and trying to figure out if my hard drive is fully fudged.

    Few weeks ago after trying to wake the laptop from sleep, things got real slow and would not login properly. Rebooted it and then would no longer boot past 3/4 of the way then turn off completely. An issue that seems to happen to several people as the impending last legs of the hard drive or system.

    Tried all sorts of the FSCK fixes I found on google in single user mode to no avail. In recovery mode, disk utility can not repair the drive as it cant be verified completely. It seems to be either a catalog issue, I/O error or file system check exit code is 8. It will not reinstall the OS either, it verifies my credentials and the system but then fails immediately after that.

    Concerned about data, I got myself a 2.5" SATA enclosure to USB and plugged it into a Windows laptop and a friends newer MBP. The windows machine can see the data via a program called HFS explorer as does the MBP. I transferred over all my files etc with basically no issues and all files are legitimate.

    I then recalled about booting the system via USB by pressing the alt/option button just after turning the machine so with the original OEM Hitachi 500GB mac drive in the enclosure (no drive connected to SATA cable inside laptop), it does not want to boot via this method at all and doesn't see the drive, just goes to network recovery? As I turn the MBP on, the light on the enclosure comes on but soon after turns off. Worried ive fudged the drive completely now, I plug it into another laptop and it runs fine. Put my hard drive back inside the actual laptop and try the select boot drive option, just incase I have not pressed right keys and that loads fine providing me the only option of loading from the internal Macintosh HD.

    I have read today about many issues with people and their SATA/hard drive cables but if this was the case, why will it start from the normal position inside the laptop but not via USB method with the same hard drive? There is no obvious clicking or loud noises from hard drive and data can be accessed fine. Is this a hard drive issue or an OS issue? I was about to format the drive and try reinstalling the OS but would be keen to know anyone that has had similar issues.

    Superdrive connection is not SATA so I cant swap to check. My hard drive SATA cable is part number 821-1226-A, the 2012 models seem to have the cable 821-1480-A, is this known to be more reliable or will it not suit my 2011?
    Thank you.
     
  2. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    I have used cheap third-party replacement sata cables from Amazon. Based on personal experience, the sata cable for the 13" early 2011, late 2011, and mid-2012 use the same cable.
     
  3. coolcicada macrumors newbie

    Joined:
    Jun 4, 2018
    #3
    Hi, I had the same exact issue on my Early 2011 just last week, randomly after shutting it down. Upon startup, there was a progress bar and it would get halfway and turn off.

    Same as you, I removed the hard drive and put it into an external enclosure and was able to read it. I think there is something wrong with the software on the hard drive, and the drive itself is fine. You might be able to fix with a reformat.

    I ended up buying a new 250GB SSD (they are quite affordable now!), put it into the computer, and installed High Sierra OS by flash drive. It works fine again. I have not tried shutting it down again though.
     

Share This Page