MacBook Pro 13 resolution problem

Discussion in 'MacBook Pro' started by Ravenscare, Feb 17, 2011.

  1. Ravenscare macrumors newbie

    Joined:
    Feb 17, 2011
    #1
    I presently own a MacBook Pro 13 (2.56 Ghz, 4gb RAM) purchased about two weeks after its release, in 2009. I use it for daily life, professional activities, and gaming.
    Until there everything's fine, but after Apple released the BootCamp 3.0 (or 3.1, don't remember) driver update, whenever I play a game on resolutions that are lower than 1280-800 I get two big black rectangles on both side of the screen, instead of the screen entirely filled, like it was prior the update.
    Of course it's two black squares... but it's awfully uncomfortable to play like, it feels... crowded.
    I don't know if I am the only, but I've never seen any other computer to which the same... anomaly(?) occurs.
    My graphic card is a GeForce 9400, 256 VRAM.

    My question: Is there a fix to this? I've played games on mac where the problem is inexistant, while it still is in Windows...
    I've tried replacing the graphic driver by NVidia's original driver install package, but no chance.
    It's getting my nerves while I'm gaming, because I am forced to play on higher resolution to do not have these empty black squares, these "wastes of space", which principally means lagg (I don't really rely on quality pictures, but much more on smooth Frames Per Second).
    I'd upload a picture soon, if I manage to represent the issue appropriately.
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    Typically lower resolutions are 4:3, so those bars are normal. You may be able to set the res lower, and stretch it before you go into the game
     
  3. mikeo007, Feb 17, 2011
    Last edited: Feb 17, 2011

    mikeo007 macrumors 65816

    Joined:
    Mar 18, 2010
    #3
    There is a setting somewhere in the nvidia control panel that allows you to set resolutions below native to either display in 4:3 mode or stretch to fill the screen. The update most likely reset this option and you simply have to change it back to stretch.

    Edit: Because I'm such a nice guy, I took a screenshot for you :) Your settings should be similar. If you click "Use Nvidia scaling" it will force the image to always stretch.
     

    Attached Files:

  4. Ravenscare thread starter macrumors newbie

    Joined:
    Feb 17, 2011
    #4
    Thanks for replying so soon, Mikeo007:)
    I indeed found what you mentionned in the NVidia Control Panel, display setting, etc... but found out the only options availables were the first two ones and the last, which means the exact one is trensparent, and unusueable... Still dunno if it's another box to check, or somethin' else. At least the NVidia scaling stretches the gaming picture, replacing the black squares, and it's good relax. I would stay like that but the picture is stretched (characters looks fatter and smaller, lolz) ; don't know what else to say.
    Oh yeah.. Thanks again for the help :D

    To return the favor I also took a screenshot:
    NVidia Utility.png
    You can clearly see the third option is transparent, thus unavailable.
     

Share This Page