Macbook Pro 13" - SSD not detected via SATA

Discussion in 'MacBook Pro' started by josh2471, Dec 11, 2013.

  1. josh2471 macrumors newbie

    Joined:
    Dec 11, 2013
    #1
    Hi everyone,

    I've recently purchased a SSD for my macbook just to give it a little extra punch. The drive however doesn't appear to be detectible when attached via the internal SATA input.

    I have formatted the SSD to Mac OS Extended (Journaled) in a GUID partition. Then using an external dock, cloned my original boot and recovery partitions to the new drive using Carbon Copy Cloner. I can now boot via the usb connection to the SSD drive but if I install it inside the macbook it can't be detected. I followed this tutorial https://discussions.apple.com/docs/DOC-4741.

    I can boot from my original drive via external usb and internal sata. I can also boot from my ssd drive with the external usb connection but not from the internal sata connection. I am using the original hard drive connecter, not anything to do with the superdrive.


    Details:

    Model Identifier - MacBookPro 9,2 (13" Mid-2012)
    SSD Drive - Plextor PX-256M5S 256GB 2.5" 6Gb/s
    Operating System - OS X version 10.8.5 (Mountain Lion)


    I hear that some people with similar issues replaced the sata cable and this resolved the problem, could this be a viable solution or just shooting in the dark? Any help is really appreciated guys.

    Cheers,
    Josh
     
  2. josh2471 thread starter macrumors newbie

    Joined:
    Dec 11, 2013
    #2
    Update:

    A mate lent me his sandisk ssd with mavericks installed. It had exactly the same issues as the previous one which means it's most likely the macbook itself.

    Any suggestions?
     

Share This Page