MacBook Pro 15" 2015: Bluetooth issues while using wifi

Discussion in 'MacBook Pro' started by melllvar, Jul 5, 2015.

  1. melllvar macrumors regular

    Joined:
    Oct 28, 2007
    #1
    Hey guys,

    I purchased the new MBP 2015 15" and am using a magic mouse with it. Everytime I use the Wifi (actively transfering data) my magic mouse stutters and or disconnects completely.

    I uses this exact same mouse with a MacBook Air in the exact same setting without problems. I also tried a second magic mouse and experienced the same issues. So I guess the problem should be the MacBook Pro.

    Does anyone else experience this kind of issue? What can I do?

    Thanks!
     
  2. sta5is macrumors newbie

    Joined:
    Jul 6, 2015
    #2
    i had the same issue with a microsoft bluetooth designer mouse. i paired it with mbp 2015 13inch and there is obvious lag and jittery mouse movement
     
  3. stanft macrumors member

    Joined:
    Jun 18, 2015
    Location:
    Hamburg, Germany
    #3
    Hi everyone,

    I had exactly the same issue with my MBP 2015 15". During heavy usage of Wifi my magic mouse keeps disconnecting. I have solved the problem by switching from 2.4 GHz to 5 GHz Wifi. But of course this is depending on your personal Wifi infrastructure because you need to have a 5 GHz Wifi at hand.

    In fact, this seems to be a common problem because I have found quite some posts on this. I wonder if Apple knows this problem and is working on a solution?!

    Regards,
    Stephan
     
  4. bryanwongxin macrumors member

    Joined:
    Jul 8, 2014
    #4
    I have the same problem like your rMBP,but mine is MBA.
    According to Genius Bar's word, there is something wrong with my MBA's bluetooth/wifi module.
     
  5. melllvar thread starter macrumors regular

    Joined:
    Oct 28, 2007
    #5
    Interesting, thanks for your posts. My MBA was using the 2.4 GHZ network without problems.
    I already talked to Apple and the guy didn't know anything about this issue. Is this an issue with all the 2015 MBPs or is our bluetooth/wifi chip faulty?
     
  6. stanft macrumors member

    Joined:
    Jun 18, 2015
    Location:
    Hamburg, Germany
    #6
    And did they exchange your logic board or similar?
     
  7. stanft macrumors member

    Joined:
    Jun 18, 2015
    Location:
    Hamburg, Germany
    #7
    Something interesting I found: In another forum somebody suggested to switch to a lower channel for the 2.4 GHz Wifi connection (i.e. channel 1-3). This has fixed the issue for some of them. Maybe worth a try...
     
  8. bryanwongxin macrumors member

    Joined:
    Jul 8, 2014
    #8

    No, because my warranty is out of date otherwise they can change it for me...
     
  9. melllvar thread starter macrumors regular

    Joined:
    Oct 28, 2007
    #9
    That doesn't have any effect on my machine. Unfortunately
     
  10. melllvar thread starter macrumors regular

    Joined:
    Oct 28, 2007
    #10
    Is there any news on this issue?

    It hasn't gotten any better here. Using a 2.4 GHZ network and bluetooth at the same time is impossible.
    As soon as I switch to 5GHZ it works without problems.. The Issue prevails in bootcamp under windows. It doesn't seem to be a OS X issue..
     

Share This Page