MacBook Pro 15'' 650M Extended Display Flicker Static

Discussion in 'MacBook Pro' started by westcoastech, Feb 9, 2015.

  1. westcoastech macrumors newbie

    Joined:
    Feb 9, 2015
    #1
    Hi guys

    I have a MacBook Pro 15'' Mid-2012 (non retina) 650M 1 GB notebook.

    I have been having issues with connecting my laptop via thunderbolt to HDMI to my TV. At first I thought it was the thunderbolt adapter (using a startech adapter) and so I replaced it. It seemed to be better for a bit then reverted back. I have also tried a new HDMI cable.

    What happens is when I am watching Youtube in full screen mode (either Chrome or Safari doesn't matter) the TV will begin to flicker black, and then it will begin to show coloured static, sometimes it only flickers for an instance while losing sound, othertimes it begins flickering many times in a row. I have lost the display a few times for about 5 seconds, it usually comes back, but once it starts it starts happening more frequently.

    I am suspecting a GPU problem, the laptop is still covered under AppleCare until Mar 2016, what is your guys opinion?

    BTW: I have placed the secondary display on mirroring and for the past day it seems to have not done the issue, not sure what that means. Also I have disabled automatic graphic switching so it is always running on the Nvidia graphics.

    Thanks
     
  2. westcoastech thread starter macrumors newbie

    Joined:
    Feb 9, 2015
    #2
    Anyone have any insight? Would be appreciate, take care.
     

Share This Page