Macbook Pro 15" A1286 won't Format

Discussion in 'MacBook Pro' started by alaltelal, Nov 3, 2014.

  1. alaltelal macrumors newbie

    Joined:
    Nov 3, 2014
    #1
    Ok, I have an unique issue. First off, I have tested all the hard drives and the SATA flex cable.

    I have two drives, both Seagate 500Gb OEM Apple hard drives. I can plug both drives in my other Macbook and mount, erase, format and partition just fine as an external drive. I install it in the Macbook in question, it takes 5 minutes to unmount, then hours to partition. I started my last test 4 hours ago, the blue status bar is still moving and the time shows: Estimated Time 1 hour 47 Minutes.

    I have followed these steps:
    I plug in other Macbook and format as external.
    I install hdd into macbook in question.
    I boot from Mountain Lion Disc (OEM)
    I go to install, and the drive does not show up at all.
    I go to Disc Utilities and the drive is visible.
    I erase and format, but just sits there all day.

    I cannot see how the problem is the flex, I have two exact same Macbooks and the flex and hard drive works just fine in the other one.

    Ive done all the basic resets too...

    So my question is, what else could the issue be? It is almost 6:00pm and I started this format after lunch. its been at least 4 hours.
     
  2. alaltelal thread starter macrumors newbie

    Joined:
    Nov 3, 2014
    #2
    Yes, I have another Macbook

    I have two A1286 Macbooks. The thing is, it's not the hard drive or the cable since I have tested both in the other macbook, installed the OS and even updated to Mavericks. I also have another cable I picked up from a used/recycle PC shop and got the same results, random failure and drives not showing up.

    I put that hard drive and flex from the running Mac into the other Macbook and I get the ? folder. I run disc utility and it doesnt see it. I remove the drive again, reformat as external on the other Macbook and disc utility sees it, but takes days to partition. Also, if I go directly to install (even after format and partition), the drive doesnt even show up.

    It's becoming random now. I've tried 4 different hard drive (2 OEM 500Gb), some read, some dont, all fail on partitioning (or take too long to run).

    Is there a hard drive controller ic that could be failing? Something similar to PC's Southbridge (not as familiar with Mac hardware as I am PC). I have done some board level repairs in the past. I'd really like to save this machine.
     

Share This Page