Macbook Pro 15" Early 2011 - Slowdown with minimal usage

Discussion in 'MacBook Pro' started by Pjstock42, Mar 24, 2011.

  1. Pjstock42 macrumors regular

    Joined:
    Jun 15, 2010
    #1
    Just looking for some input on this.

    I just received my 15" MBP i7 2.0ghz, SSD, 4gb ram last week.

    When I have the game "minecraft" open, I can barely scroll around webpages in safari or chrome when i minimize it. minecraft is not really a demanding game and i could minimize minercaft and multitask fine with my old acer ferrari one netbook that i had before this.

    I'm just not understanding why there would be such significant slowdown on a brand new $2000 machine when I'm barely stressing it at all.

    Any help?
     
  2. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
  3. Pjstock42 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #3
    I dont think thats the case.

    This has happened each day I've owned the machine.

    Only Chrome and Minecraft opened, extreme slowdown with minecraft minimized, can barely scroll through web pages and the dock is laggy.
     
  4. Looon macrumors 6502a

    Looon

    Joined:
    Jul 10, 2009
    #4
    A brand new $2000 machine with technology from 2007
     
  5. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #5
    In terms of?
     
  6. Drecca macrumors regular

    Joined:
    Aug 30, 2010
    #6
    it happens because the dedicated graphics card isn't turning on. I have the same issue with Minecraft and WoW (i.e : they'll work once, close them off, come back to them later in the day and they'll use the integrated gfx card).

    very annoying problem. A reboot is the only thing that fixes it
     
  7. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #7
    Also you might want to do a PRAM (I/O) reset too
     
  8. Pjstock42 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #8
    Hmm, I see in energy options you can turn off automatic graphics switching and itll stay on the dedicated card permanently with that option disabled (i think).

    I'll try and see if that works.
     
  9. hehe299792458 macrumors 6502a

    hehe299792458

    Joined:
    Dec 13, 2008
    #9
    Try looking for a software called gfxcardstatus. No clue why apple doesn't include something so simple and useful in their OS
     
  10. Macsavvytech macrumors 6502a

    Macsavvytech

    Joined:
    May 25, 2010
    #10
    Normal behaviour if this annoys you go complain to notch its a Minecraft bug not the Macbook Pro This Happens on every computer i have used including a Mac Pro
     
  11. Macsavvytech macrumors 6502a

    Macsavvytech

    Joined:
    May 25, 2010
    #11
    Oh and Minecraft may not be that demanding but it still uses 1.2GHz of your CPU when just walking around and will guzzle ram like mad, unfortunately this as i said above is not a problem with your computer but just how minecraft is coded abit like alot of things notch does ;(
    PS: You wouldn't have noticed that many bad thigns unless your a server admin
     
  12. Pjstock42 thread starter macrumors regular

    Joined:
    Jun 15, 2010
    #12
    Downloaded this, switched to discrete only and it does seem to be making a difference, thank you very much for the suggestion.

    For people blaming the coding of the game, I assume youre just talking about the Mac version? Because I've ben running Minecraft and multitasking fine on windows machines with less than half the power of this MBP with no issues.
     
  13. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #13
    The game code is partially to blame, but really it's Apple's (or has Oracle finally taken it over now?) implementation of Java in OSX. It's unfortunate, and I really wish there was a better way than booting to a different OS to play for right now. I play on my Mac with my graphics on fast (view distance still set to far) and smooth lighting off (I prefer "rough" lighting anyway) and it works fine for the most part, so long as I'm not playing on my external display. That's what my desktop is for.

    Notch has stated that the game won't be fully optimized until release, but rather he will optimize as he continues to build the game. However, these issues aren't the major factor in the game performance on OSX. It does however cause issues for SMP admins :/
     
  14. Looon macrumors 6502a

    Looon

    Joined:
    Jul 10, 2009
    #14
    Whenever a piece of software doesn't run as good on Macs people always blame it on the software, seems to me the one common link in all these problems is OS X.
     
  15. 87am macrumors regular

    Joined:
    Feb 27, 2011
    #15
    Totally dude. OSX is so unstable and buggy. Dont even think about running any "profesional" applications on it, just asking for trouble!
     
  16. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #16
    I don't think anyone is stating that. I'm just trying to say that the Java implementation in OSX is pretty poor, which I would imagine is why Apple handed that responsibility off to Oracle.

    OSX is great, there are just some issues with 3rd party libraries and API's such as Java that need to be worked out.
     
  17. ECUpirate44 macrumors 603

    ECUpirate44

    Joined:
    Mar 22, 2010
    Location:
    NC
    #17
    Please explain?
     
  18. Macsavvytech macrumors 6502a

    Macsavvytech

    Joined:
    May 25, 2010
    #18
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    PS: I'm a server admin :S
     
  19. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #19
    Just a troll, nothing to see there.
     
  20. systole macrumors member

    systole

    Joined:
    Mar 24, 2011
    Location:
    Minnesnowta
    #20
    Java Settings

    I believe that the default maximum ram allocation for a java application on osx is 512 megabytes... Try running minecraft natively instead of in the browser, and try to find the java control panel. There should be a setting in there similar to the command used to run the server under linux.

    --from minecraft.net

    Change the 512MB to 1024, and you should see drastically better performance.

    Sorry I can't be of more help... Waiting on my replacement MBP. 4 hours of waiting for the Fed-Ex flight from shanghai to arrive in memphis :eek:
     
  21. Stevamundo macrumors 6502

    Stevamundo

    Joined:
    May 18, 2008
    #21
    LOL! You know that I sometimes read the threads just for comedy.

    Yeah dude I do ALL of my work on my Macs. Everything from web designing, word processing and spreadsheets. The OSX hasn't failed me yet.

    As for this thread, have you installed 10.6.7 for the 2011 MBP's yet?
     
  22. WillEH macrumors 6502a

    WillEH

    Joined:
    Feb 8, 2011
    Location:
    United Kingdom
    #22
    Why do we have to mix with these window minorities, what has the world come to!?!?! :rolleyes:
     
  23. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #23

    There is a way, if you right click the Minecraft.app and show package contents. Then go to the "info.plist" file and edit it with a text editor, near the bottom there is a value which reads similar to

    "<string>-Xms1536M -Xmx1536M</string>"

    Near the bottom of the file. As you can see, mine is edited to allocate 1.5gb. There is definitely a difference when playing single player, but I didn't notice a drastic change in multiplayer personally.
     

Share This Page