Macbook Pro 15" late 2008 no power input

Discussion in 'MacBook Pro' started by bs180, Feb 12, 2014.

  1. bs180 macrumors newbie

    Joined:
    Feb 12, 2014
    #1
    Hi there folks!

    as i'm pretty new on mac computers, i had the idea of writing my problem down and posting it in the forum here, in hope to get some advice.

    here's my story/problem:
    recently, the macbook pro 15" (late 2008) of my girlfriend refused to charge with the "usual" 85w magsafe power supply which she was using for the past years. so, symptoms here are: no orange or green light, not even a dim green light as some users report, just nothing at all.
    because i'm a self-repair-guy and a computer technician (usually building or fixing windows-pc's, hardware and other stuff), i thought i could give it a try and fix it myself.
    so first i thought, there might be an issue with the power adapter itself. so i swapped it with a working one of a friend who has the exactly same macbook (his powersupply was working on his macbook), hooked it up, but still nothing.
    alright, my suspicion was growing that there was something wrong with the macbook itself, but let's continue.
    surprisingly, the macbook could still run on battery for a few minutes!
    next step i tried was to swap my gf's battery against the newer (and fully charged) battery of my friends macbook, and voila! the macbook was running fine for 3 hours and i was able to do a complete timemachine-backup.

    so, the mbp itself runs just fine, it just won't charge the battery or run on the powersupply itself.

    so, all leads to the conclusion, that there's something wrong with the macbook-internals, likely with the dc-in adapter or worst case: the logic-board.
    i've read a few topics of people who had a dim green light on their magsafe power adaptor and a few of them tried an smc-reset and were able to solve their problem. i gave it a try myself, but no luck in my case...

    in my opinion, it has to be some kind of fuse that got blown, right where the power goes into the mbp. otherwise, it wouldnt run fine on battery power.

    as you see, its a pretty old mbp, but we dont have much money left and it would be great if there was a way to fix it without replacing the whole logic-board or buying a new macbook.

    does somebody got an idea or even a fix on this issue? has one of you guys had the same problem?
    or does somebody have some kind of circuit diagram of the mbp late 2008?

    thank you guys in advance for your help/inputs.
    and sorry about my english, it's not my first language.

    greetings from switzerland :)
     
  2. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #2
    If you're lucky it may just be the DC-in portion of the MagSafe connector on the MacBook itself. You could try to replace that first.

    I typically use PowerBook Medic when I need parts like this. I don't know details of their shipping out of the US, but the part you're looking for runs $20 used here.

    http://www.powerbookmedic.com/Magsafe-DC-IN-Board-for-MacBook-Pro-15-Unibody-p-17273.html

    I'm sure there's other places with it, just using them as a reference.

    There is an excellent guide on iFixit for this repair here: http://www.ifixit.com/Guide/MacBook...08+and+Early+2009+DC-In+Board+Replacement/834

    Best of luck to you!
     
  3. bs180 thread starter macrumors newbie

    Joined:
    Feb 12, 2014
    #3
    hi brettapple!
    thank you very much for your hint. i'll definitely give it a try.
    i've already hoped it could be the dc-in-unit and not the logic board. this would save me some money (actually, a lot of money).
    thanks for the link to the shop. i'm not sure what the shipping costs and extra toll would be, so i'll look for the part from a reseller around here.
    i'm gonna write back a soon as i got news.

    greetings!
     
  4. Astroboy907 macrumors 65816

    Astroboy907

    Joined:
    May 6, 2012
    Location:
    Spaceball One
    #4
    Have you tried an SMC bypass (different than SMC reset)? How about resetting the PRAM?

    It wouldn't likely be the fuse, more likely a DC board/Logic board issue. You can check though, I believe the main logic board fuse is located right next to the magsafe connector on the board.
     
  5. bs180 thread starter macrumors newbie

    Joined:
    Feb 12, 2014
    #5
    hi there astroboy!
    i haven't known about the smc bypass and gave it a try yesterday evening with no luck. no response from the mbp at all...
    so if i'm guessing right, this means the smc is not causing the problem.
    somehow it confuses me. but in my eyes this means that the problem is the power-flow on the mbp in general and not the smc. otherwise it should've started right up with fans at full speed etc. right?

    as next step, i'm going to measure some inputs on the dc-board/logic board to see if there's any power flowing.
    maybe i can even detect a blown fuse or something similar.
    what do you think?
    thank you guys for your suggestions and answers. this problem seems to be a tough one...

    i'll write again as soon as i have some more informations! :)
     
  6. bs180 thread starter macrumors newbie

    Joined:
    Feb 12, 2014
    #6
    hey guys, its me again. today i measured a few things on my mbp.
    status so far:
    1. mbp not charging and not running from magsafe adapter.
    2. no light at all on the magsafe connector
    3. mbp running fine from charged battery (just have to charge it with another mbp)
    4. smc reset and smc bypass won't work at all (no turning on)
    5. apple power supply ok (outputs 6.8 v in "no load"-mode)
    6. dc-board seems to be ok (6.8 v going in and coming out the cable to logic board)

    so, i ordered a new dc-in board anyways, but i seems this isn't the problem.

    next step in my opinion would be to check the logic board.
    any ideas where to start?

    thank you very much for your responses
     
  7. Astroboy907 macrumors 65816

    Astroboy907

    Joined:
    May 6, 2012
    Location:
    Spaceball One
    #7
    I thought the chargers were supposed to output closer to 18v, but I'll have to check on that. Have you tried a different charger plugged into a different outlet?
    If there is no light on the MagSafe, then the SMC controller is likely not responding properly (it controls the light). Maybe posting some pics of the logic board would help as well.
     
  8. bs180 thread starter macrumors newbie

    Joined:
    Feb 12, 2014
    #8
    hi there astroboy!
    hmm, i've read (on wikipedia) that the charge supplies 6.8 v under no load, whilst 16.5 v under load. the problem is to determine "load"/"no load".
    does this mean the charger outputs 6.8 if not plugged in and if plugged in for example charging the battery or computer idle 16.5 v?
    unfortunately, i don't have a spare second adapter to test at the moment, but i'll get one from a friend of mine really soon to check that out.
    i've ordered a new dc-in board to check if this could be the problem (hopefully!). it takes 2-3 weeks to arrive, so i guess i'm stuck right now with my problem.
    i'll pot back as soon as possible!

    many thanks to all of you for trying to help me out!
    greetings
     

Share This Page