Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

igauravarora

macrumors member
Original poster
Feb 16, 2017
93
147
Hi,

I initially put the beta on my machine oblivious of the fact that there's this T2 chip which has it's own OS (bridgeOS) which once updated cannot be downgraded unless you have another Mac laying around. So, even when I downgraded to Catalina I was experiencing boot delays and the boot chime didn't go away. I was kinda bummed out because I was still running beta code on my machine which I cannot get rid off.

Today, I jumped back on the public beta bandwagon just to update the bridgeOS so it could get rid of the boot delay, at least that's what I was hoping for.

Now, about the boot delay. On the Public Beta 1 it took total of 15 seconds from the moment I hit the power button to get to the boot chime+Apple logo to appear and then it took about 30 seconds to get to the login screen. Total of 45 seconds.

On Public Beta 2, It takes the same initial 15 seconds from pressing the power button to boot chime+Apple logo to appear but then it takes another 15 seconds to get to login screen. So a total of 30 seconds.

Now, I want to know if this is the normal behaviour? Should it initially take 15 seconds for the Apple logo and Boot chime? was it the same on Pre-Big Sur MacBook Pro 16" machines? Can anyone who is still on Catalina confirm how does the boot sequence look like?

This might be a minor annoyance for some but it's kinda major for me.

A side note: I'm kinda bummed out because my old baseline MacBook Pro 2017 ntb booted really quickly, the apple logo appeared the instant you clicked the power button or open the lid.

Thanks.
 

verdi1987

macrumors 6502a
Jun 19, 2010
632
398
On my 2018 MBP 15”, there is a 22-second delay prior to the boot logo appearing. It is 22 seconds whether I boot by opening the lid or by pressing the power button.

I did a clean install for beta 5 (completely reformatted the internal disk), and the delay still persists. Hopefully, this gets fixed soon.

I had no delay with Catalina.
 
  • Like
Reactions: igauravarora

igauravarora

macrumors member
Original poster
Feb 16, 2017
93
147
On my 2018 MBP 15”, there is a 22-second delay prior to the boot logo appearing. It is 22 seconds whether I boot by opening the lid or by pressing the power button.

I did a clean install for beta 5 (completely reformatted the internal disk), and the delay still persists. Hopefully, this gets fixed soon.

I had no delay with Catalina.

The most ****** part of all this is even when I downgrade back to Catalina, the boot delay still remains! Apart from this boot delay my machine also doesn't wake up from a deep sleep state. It hangs, then the fans sped up for 2 second and it crashes to this white text. I have reported it in the feedback.

I have tried several ways to fix this, resetting smc and nvram, clean install with usb drive but nothing helps.
 

Mortis360

macrumors regular
Sep 6, 2013
154
88
Norway
I also have this issue, most likely related to bridgeOS in some way, not fixed with b5. We'll have to wait for a new version of bridgeOS that contains a fix for this.

My feedback shows there are more than 10 similar recent cases filed,I don't believe they show anything more than that to anyone.
 
  • Like
Reactions: igauravarora

igauravarora

macrumors member
Original poster
Feb 16, 2017
93
147
I also have this issue, most likely related to bridgeOS in some way, not fixed with b5. We'll have to wait for a new version of bridgeOS that contains a fix for this.

My feedback shows there are more than 10 similar recent cases filed,I don't believe they show anything more than that to anyone.

Thanks for the reply. Do you also have the sleep wake issue? my MacBook won't wake up if it's asleep for more than an hour. It just hangs there for few minutes then fan sped up and it crashes to this white text screen. It reboots afterwards and runs fine as long as it doesn't go into deep sleep.

I also made a post on reddit about this sometime ago-

link
 

T-Bob

macrumors 6502a
Oct 23, 2013
675
363
Was fixed in 7 thankfully, so was the smb bug. Not sure whats new in 8 yet.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.