MacBook Pro 2009 booting very slow / SSD doesnt work

Discussion in 'MacBook Pro' started by any-key, Jan 7, 2013.

  1. any-key, Jan 7, 2013
    Last edited: Jan 7, 2013

    any-key macrumors member

    Joined:
    Sep 12, 2012
    #1
    I have a problem with a mid 2009 MacBook Pro (15 inch). It is running the latest version of ML. And has all original parts. No RAM or Harddrive was exchanged.

    With time it was booting slower and slower. At the moment it will boot in over 3 minutes. I havent seen that on any other MacBook I ever owned.

    So I decided to buy an SSD as I did for my brothers MacBook Pro 13 inch form 2009. But in the 15 inch I just cant get it to work. I tried a Samsung 830 128 GB first (same model that runs perfectly in my brothers MacBook Pro).

    First attempt with the Samsung 830 SSD the clean install of ML from a USB thumb drive always fails in the middle of the install process giving copy errors ("copier error 22"). Second attempt with the Samsung SSD was using OS X Lion from a thumb drive. Same issues. Then I tried to go from the original Leopard Install DVDs that came with the MacBook. Exact same thing. I also tryed cloning the Mac's disk to the SSD. I could boot OS X but it was crashing all the time. Freezing the OS and so on.

    I checked the SSD using Diskutility multiple times. No issues detected. And it even runs fine within my Windows Desktop system atm.

    Second SSD I tried was a OCZ Vertex 2 128 GB. I tried all the steps like I did with the Samsung SSD. Again no luck to make a clean install of OS X. What is it that I am missing? The same SSDs and clean install worked flawless on my brothers MacBook form 2009 and also on my MacBook Pro 15 inch from 2010.

    Any suggestions why on earth the 15 inch from 2009 wont work?
     
  2. makaveli559m macrumors 6502

    Joined:
    Apr 30, 2012
    #2
    Hi have you checked your RAM? Could be a RAM issue, have you also checked for any firmware updates? I hope when you changed the drive that you grounded your self against any static shocks.
     
  3. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #3
    It's possibly a bad SATA cable. That world explain the errors when trying to install the OS and it may be why you were experiencing such dramatic slowdowns on your old HDD.
     
  4. any-key thread starter macrumors member

    Joined:
    Sep 12, 2012
    #4
    I was reading about bad RAM beeing the issue in some cases. I was running Hardware checks on the RAM. Both modules where reported as beeing fine. I also tryed using only one of the two modules during install. No changes.

    Thats something I havn't checked. Any idea where I can get replacement cables (preferebly from within europe)?
     
  5. makaveli559m macrumors 6502

    Joined:
    Apr 30, 2012
    #5
    eBay it, hopefully someone would have the parts available there.
     
  6. any-key thread starter macrumors member

    Joined:
    Sep 12, 2012
    #6
    No luck for my MBP model. I'll try to find one and report back if it solved the problem.
     
  7. any-key thread starter macrumors member

    Joined:
    Sep 12, 2012
    #7
    Problem Solved

    I finally found a SATA cable on eBay. After installing it I managed to install OSX ML on the SSD. However I experienced issues like the "repair permissions" in Disk Utility found wrong permissions but couldnt fix them.

    So after reading a few more old threads I also downgraded the EFI Firmware from 1.7 to 1.6. This finally solved also those problems.

    The Samsung SSD is running perfectly now. The MBP boots and runs much faster now. And Safari also feels snapier :)

    Thanks fo the help guys.
     

Share This Page