Macbook pro (2009) Freezes when trying to wake from sleep

Discussion in 'MacBook Pro' started by juulie, Aug 9, 2009.

  1. juulie macrumors newbie

    Joined:
    Jul 26, 2009
    #1
    Hey guys,

    Since the 10.5.8 update my Macbook wont wake from sleep (black screen) and i have restart it with the power button. The Macbook is totally frozen: the keyboard doesnt respond (caps button light wont go on and etc.) and my external monitor wont come on either.

    What I've tried:
    -Install combo update 10.5.8 (i did normal update first time)
    -Started up with all the magic keys combos (PRAM and SCM or whatever)
    -Tried the fix where you need to (re)enable the ethernet port
    -Set sleephibernate mode to 0
    - Repaired permissions and disk aid etc.

    Can anyone help me with this?
     
  2. Devtron macrumors newbie

    Joined:
    Jun 24, 2009
    #2
    I have had this mac for a few months, and once in a while it will freez, when i try to wake it.
    It did before the latest patch and after.

    Strange little problem.
     
  3. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #3
    I had a freeze once after the 10.5.8 update. I did not have the issue before 10.5.8. Must be some compatible problems happening.

    I haven't done anything yet. It happened only once.
     
  4. TheHoff macrumors 6502

    Joined:
    Oct 22, 2008
    #4
    Same here.

    I never had a sleep/wake issue before 10.5.8. Now today it has frozen twice when waking up -- MBP 15" 2009 unibody

    I went to post this on your thread in the Apple Support Forums but the login/registration was broken. I'm repairing permissions now but I don't have a lot of hope that it will fix it.
     
  5. juulie thread starter macrumors newbie

    Joined:
    Jul 26, 2009
  6. MacModMachine macrumors 68020

    MacModMachine

    Joined:
    Apr 3, 2009
    Location:
    Canada
    #6
    shut off dim display before sleep.

    causes some sleep problems with certin machines.
     
  7. Z06jerry macrumors regular

    Joined:
    Feb 2, 2008
    Location:
    Ontario, Canada
    #7
    Pardon my ignorance, can you explain what this is?
     
  8. juulie thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #8
    I forgot to paste the details of the error log:


    Interval Since Last Panic Report: 105250 sec
    Panics Since Last Report: 13
    Anonymous UUID: AE0175B6-2007-4812-82BF-EFF25F7FD325

    Mon Aug 10 14:00:18 2009
    panic(cpu 0 caller 0x001B32B3): "Error 4 trying to transition CPU 1 to OFF"@/SourceCache/xnu/xnu-1228.15.4/osfmk/i386/acpi.c:154
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x5653fd28 : 0x12b4c6 (0x45f91c 0x5653fd5c 0x13355c 0x0)
    0x5653fd78 : 0x1b32b3 (0x46b21c 0x4 0x1 0x3f36a7)
    0x5653fda8 : 0x50615ffe (0x50615e50 0x3 0x246 0x131e9a)
    0x5653fdc8 : 0x5060a44c (0x6609800 0x2 0x0 0x6723300)
    0x5653fde8 : 0x43a8a9 (0x6723080 0x53d848 0xffffffff 0x0)
    0x5653fe38 : 0x44cb7f (0x6609800 0x4a78d4 0x5653fe68 0x6f39780)
    0x5653fe88 : 0x41acd1 (0x660f000 0x4 0x1d 0x2)
    0x5653fec8 : 0x41ad93 (0x660f000 0x0 0x1 0x66fb680)
    0x5653fee8 : 0x42174c (0x660f000 0x123d3700 0x0 0x6610f00)
    0x5653ff38 : 0x41bd73 (0x660f000 0x123d3700 0x66fb680 0x0)
    0x5653ff68 : 0x425d58 (0x66fb680 0x1 0x5653ff98 0x4255b1)
    0x5653ff98 : 0x425a3a (0x6610f00 0x0 0x12951128 0x41c978)
    0x5653ffc8 : 0x1a14fc (0x6610f00 0x0 0x1a40b5 0x73746b0)
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.driver.AppleACPIPlatform(1.2.5)@0x50609000->0x50646fff
    dependency: com.apple.iokit.IOPCIFamily(2.6)@0x505a1000
    dependency: com.apple.iokit.IOACPIFamily(1.2.0)@0x505b8000
     
  9. juulie thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #9
    did fresh install to SL (and recoverd files from TM) but problem persists...
     
  10. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #10
    Same thing happened to my MBP 2009. After upgraded to 10.5.8, I got freeze on resume from time to time.
     
  11. cu2010 macrumors 6502

    Joined:
    Jun 8, 2009
    Location:
    new york city
    #11
    Mine is password protected, and at times the password box doesn't appear when I try to wake it. Usually, I just need to close the lid and open it again, but last night I had to restart it with the start button.
     
  12. juulie thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #12
    Called support (have the extended warranty) but waited for more then 25 min in line so i hang up, thinkin about bringing it to an service provider (we dont have geniuses here in NL)
     
  13. lyl macrumors member

    Joined:
    Jan 14, 2009
    #13
    same problem here
    i got the pw box but cant type anything
     
  14. marcs macrumors newbie

    Joined:
    Aug 31, 2009
    #14
    i had two white macbooks recently that flooded the network switch knocking out the dhcp to that switch ( none of the computers connected to that switch could obtain an IP). On both occassions both had gone to sleep and not woken up. White battery light constant. Had to force shutdown. I took them off the network and everyone on that switch could connect again. They were both on 10.5.8.
     

Share This Page