Macbook Pro 2010 + OCZ SSD - Cannot erase/partition

Discussion in 'MacBook Pro' started by wood0004, Sep 4, 2011.

  1. wood0004 macrumors newbie

    Jun 16, 2010
    I have a Mid-2010 MBP 13-Inch. For the last year, I have used an OCZ 120GB Vertex II SSD as the primary drive with no trouble at all. Last month I performed a clean install of Lion from USB Flash Drive and it has been working well except for the audio bug.

    Two days ago, the system started getting very sluggish and finally there was a kernel panic and the system restarted. Upon restart it failed to boot OS X. I went into the disk utility in recovery and verified an then repaired the disk after which I was no longer able to even boot to recovery. Using

    I pulled the SSD and installed in my Windows 2008 Server and all of the data was intact so I copied it over to the server. While installed in the server, I updated the firmware to I believe 1.33 from 1.22 and then wiped the drive.

    When I reinstall in the MBP and run disk utility, I cannot erase and partition as I get the error "Wiping volume data to prevent future accidental probing failed". I can partition, format, write, read using Windows with direct SATA connection also using iMac and Mac Mini with USB to SATA adaptor. I have even tried formatting the drive using one of my other Macs and trying to install to it but install always fails. It is als interesting that using Disk Utility I cannot select security options.

    I was sure that the problem was motherboard related but today I tried my original Mac Hard Drive (320GB Hitachi) and partition/format/install work flawlessly.

    Any ideas?
  2. wood0004 thread starter macrumors newbie

    Jun 16, 2010
    Thank you for the quick reply; however no luck.

    I can run options 1 and 2 from this MBP and both fail with the "Wiping volume data to prevent future accidental probing failed", with Terminal I get the message along with Error: -69825.

    Options 1 and 2 work perfectly on this MBP using the non-SSD that came with the MBP. Options 1, 2, and 3 work perfectly on the Mini and iMac using this SSD.

    The only thing I cannot try is to install this SSD into another MBP to see if it works. I want to know if it is SSD problem or MBP problem as new SSD I can order if necessary but MBP repair I have to bring the system to Hong Kong which costs me a day of work + repair cost. Of course my warranty expired last week too.
  3. treestar macrumors 6502

    Feb 28, 2010
    I think you just need to erase the SSD and format it for GUID. You can do that on any system and then move it back to the MBP to install OS X. You should be able to do that on the MBP if you are running the Lion utilities from the USB disk, but since you cannot there might be a serious, unresolvable problem with the SSD. Try your best to get it erased from another system and go from there.
  4. wood0004 thread starter macrumors newbie

    Jun 16, 2010
    I have also tried a full erase and partition on another system; however, Lion fails to install on this drive. For whatever reason my MBP can erase a partition but not create and cannot allow install; but only using this SSD. Normal HD is no problem and this SSD works fine in Windows and Mac OS on different systems. The only thing I cannot try because I have no other MBP around is to actually install this SSD in another MBP and try.

    At this point it is essentially a coin toss as to whether this is SSD or MBP problem. I am in Southern China so I have to decide to spend the money and order a new SSD or spend a couple of days in Hong Kong while they swap out the MB.
  5. wood0004 thread starter macrumors newbie

    Jun 16, 2010
    Definitely a MBP issue. I installed Lion on the original HDD that came with te system. Every couple of minutes the system pauses for 1 - 5 minutes (can move mouse cursor but do nothing) until finally I receive kernel panic. Will run the Mac diagnostics to identify the problem.
  6. epistememe macrumors newbie

    Sep 20, 2011
    2011 17" MBP with similar problems

    I have installed a Vertex3 in the optical drive bay as a second drive. I can't erase and get the same error and also no luck with the Apple suggestions.
  7. shortcut3d macrumors 65816

    Aug 24, 2011
    2011 Mac Mini + OCZ Problem as well

    I was able to install an OCZ Vertex 3 MAXIOPS flawlessly on one of two 2011 Mac Mini's. The second identical setup (sequential serial numbers on OCZ Vertex 3 SSDs) received this error. I connected the SSD via FW800 adapter a to a 2010 27" iMac with Lion OSX 10.7.1 and was able to partition and format. Then in the Mac Mini, I was able to re-partition using Bootcamp and format the Windows 7 partition during install. The SSD passed BlackMagic Disk Speed stress test in the Mac Mini.

    In my situation, it was potentially a SATA cable that was not fully seated. Upon taking apart the Mac Mini to remove the drive for formatting in the iMac, I noticed the foam "bumper" between the two drives was lifting the SATA cable, the heat shield prevented the cable from disconnecting.
  8. piresivan macrumors newbie

    Jan 13, 2012
    The same problem

    I have MacBook pro A1286 and I have the same problem, but with my internal HD,

    I did everything...Replaced the HD, the internal cable and nothing...always the same error.

    I had format the HD from another PC, but when I try to install the mac os (any version) the installation return error.

    The only way to make the HD works is connecting by USB.

    This command from terminal didn't works from me, but maybe with somebody works:

    diskutil partitiondisk disk0 JHFS+ newdisk 100%

    The error return:
    -69825: Wiping volume data to prevent future accidental probing failed
  9. Goghard macrumors newbie

    Feb 5, 2012
    Solution with Leopard hackintosh and USB-SATA adapter

    I had a similar problem: I couldn't re-install Lion in a 2010 MBP, because it was unable to set the new partition or unmount the damaged one.
    I fixed the problem this way:
    - Connect the disk in a PC with a Hackintosh Leopard (10.5) using the standard SATA cable.
    - Check the disk with MHDD (if you have bad sectors, you can fix it) .
    - Fix the partition table following this post:
    - Use the Disk Utility in Leopard to erase and create the new partition. (Maybe it works with a original Leopard DVD in a Mac machine).

    When I connected the disk in my MBP, it recognizes the new partition, but still was unable to install because it couldn't unmount the disk.

    - So, I turn off the mac, and connect the disk in the USB port with a SATA-USB adapter.
    - Again run the Lion setup (It works via USB!)
    - With the system installed and running via USB, update it to 1.7.3.
    - Turn off again and reconnect the disk to the SATA cable.
    - The system will boot slowly (about 3 minutes).
    - Select the start up disk in System Preferences and fix permissions to reduce boot time to 30 seconds.

    This is my first post here, so I hope it helps.
  10. javy1986, Aug 20, 2012
    Last edited: Aug 20, 2012

    javy1986 macrumors newbie

    Aug 20, 2012
    Sorry for the bump but I've got the exact same issue on a mid 2010 13" MBP.

    It suddenly freezed up yesterday. After the freeze I was unable to boot the machine.

    I'm using a SSD and the original HDD in the Optibay so at first I thought my SSD drive died. I swapped the HDD and put the SSD in the Optibay and I was able to boot my MBP.
    However this time I am unable to Mount, repair or format my HDD. It looks like the Primary SATA port is dead.

    Did you have any luck on fixing this?
    EDIT: After doing some more reading it looks like this is related to the MBP sata cable. I've ordered a new cable on Ebay, when I get it I will post my results.
  11. Wondersnite, Mar 4, 2013
    Last edited: Mar 4, 2013

    Wondersnite macrumors newbie


    Jan 14, 2010
    Bump again. I'm experiencing the exact same issue as the OP. I can't use my Mac at all right now. Did anyone find a solution or should I give up and get a new hard drive?
  12. gepia macrumors newbie

    Mar 23, 2014
    Problem - faulty SATA cable

    Hi all, I've strugled for some days with the same problem but now it is solved. The problem was a faulty SATA cable. I've replaced it with a new one and now everything works as expected.
  13. illkitty macrumors newbie


    May 26, 2016
    I understand I am posting in a "dead" thread, however, this is the main page that everyone comes across when searching for this issue on Google.

    This was in fact a faulty SATA Cable issue I had as well. It seems unusual, but the following steps lead me to get the problem resolved.

    1.) I had a Customer who went to the Apple store, and told them that they had a defective Hard Drive. The Customer purchased a New 512Gig Samsung SSD, but wanted us to install the Operating System for him.

    2.) I had lag & issues just trying to format the Hard Drive, and even when using multiple Apple OS install media (flash Drives & Discs with different versions of the OS the Laptop could take).

    3.) I pulled the Drive & confirmed it worked in other systems by confirming I could format & read from the drive.

    4.) I followed the valuable suggestion of someone on the site here to plug in the Drive (via a USB to SATA Cable) & install the Apple OS that way.

    5.) Everything went fine, but I had super slow response times when I put the drive back into the Hard Drive connector & tried to boot normally.

    6.) Repair disk does help with with the boot times, and I did not see any damage at all to the SATA Hard Drive cable or the connector on the board.

    7.) After everything I Read here, and all that testing, I overnighted the replacement cable, installed it today, and the system booted incredibly fast. Problem solved!

    Note: Thanks a ton to ALL of you, who over the years assembled such a detailed description of the problem, and the solution to lead people like me to getting the Laptop working again. :D
  14. Enjay314, Jun 8, 2016
    Last edited: Jun 13, 2016

    Enjay314 macrumors newbie

    Oct 2, 2012
    For those that find this thread later, while you can order a SATA cable at Amazon for 14$, one of the reviewer's comments describes the problem and a fix with a bit of electrical tape.

    It sounds like the tape fix works for many people but did not work for me.

    Basically the hard drive cable rubs against the edge of the optical drive's metal tape and probably gets shorted in some way.

    One solution is to put a little piece of electrical tape between the SATA cable and the optical drive.

    When I tried this with a Samsung SSD the first time it didn't work. So I used some rubbing alcohol (99% in this case) and swabbed the back of the SATA cable where it rubs the optical drive.

    Then I put the electrical tape on the optical drive edge instead of the cable (since it was easier this way anyway) and the drive allowed me to format it and install the OS.

    However, it stopped working once I put the back of the computer back on. In the end I just ordered and installed the cable and it appears to be working much better. I did reinforce it with electrical tape to future proof it!

Share This Page