MacBook Pro 2011 13" - Sierra Downloading Issue

Discussion in 'Mac Apps and Mac App Store' started by InsertNombre, Feb 3, 2017.

  1. InsertNombre macrumors newbie

    Joined:
    Sep 1, 2011
    #1
    Hi everyone,

    I recently upgraded my early 2011 13" MPB to a 1TB SSD and 16GB of RAM from the original specs. I started completely new on the drive and I finally managed to install Lion after many attempts. My software on my Mac is currently Mac OS X Lion 10.7.5.

    Once I was able to install Lion, I went straight to the App Store to try and upgrade to MacOs Sierra. Everything was going fine until I got to about 3.85GB downloaded and then I got a message saying that the application could not be downloaded and to check my internet connection and try again. Nothing was wrong with internet connection, so I did not know what the problem was. I tried downloading again, but got the same message.

    After repeating the process a couple of times, I hit cancel, rebooted my Mac, and tried to download it again, but that did not work either. This time I was getting a different error message though. It said that the purchase could not be completed, that the product distribution file could not be verified, and that it may be damaged or was not signed.

    I then started googling the error to see if anyone else had the issue, but had no luck with a solution. I tried one suggestion saying to create a new user on the Mac and download it from there, but did not have luck with that either. I tried another about downloading in Safe Mode, but no luck either.

    I am at my wits end trying to figure out how to use my laptop again. I have been fighting with it for a couple of days now - first with installing Lion and now with updating my system. Oh, I also cannot perform Software Updates from Apple logo on the top left corner. It checks for software, finds "Security Update 2014-004" and "iTunes", but gives me an error message when I try to update them. The error states "None of the selected updates could be saved. This update could not be verified. It may have been corrupted during downloading. The update will be downloaded and checked again the next time that Software Update runs." I was able to perform software updates. Still can't download Sierra, though

    Any help anyone can provide will be greatly appreciated as I am unsure what to do.

    Thank you for your time!
     
  2. InsertNombre thread starter macrumors newbie

    Joined:
    Sep 1, 2011
    #2
    I was able to fix it. Turns out, it was my internet causing me issues. When I went to parent's house, Sierra was able to download in about 1.5 hrs. I was using Comcast, they have AT&T.
     

Share This Page