MacBook Pro 2011 external display flicker (even after software update)

Discussion in 'MacBook Pro' started by RoboCop001, Jun 19, 2011.

  1. RoboCop001, Jun 19, 2011
    Last edited: Jun 27, 2011

    RoboCop001 macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #1
    I just replied to the News Discussion topic of the same nature, but I thought I'd start a specific thread here (didn't find one) since this problem is still happening for some users like me.

    I just upgraded to a custom-ordered MacBook Pro 15 inch from a 2006 MacBook Pro last week.

    I would often connect my computer to my Samsung HD TV in clamshell mode without any problems.

    But ever since I upgraded to the 2011 MacBook Pro the TV has the flickering problem. Actually, sometimes the TV's internal speakers would make a "pop" sound.

    I'm using Mac OS X 10.6.7 build 10J4139. I noticed the MacBook Pro Software Update 1.4 supposedly gives you build 10J4138 so I'm assuming this software fix is present in my computer. The updater would not run on my computer (probably because it's already installed). Obviously it hasn't fixed the problem for everyone.

    I'm hoping they fix this really soon because I can't afford to buy a new TV just so that my MacBook Pro works properly with it. On top of that, the TV is only 2 years old.

    I've submitted a bug report to Apple and also replied to a similar topic on Apple Discussion forums.

    Anyone else still having this problem?
     
  2. RoboCop001 thread starter macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #2
    After applying today's Thunderbolt Firmware update, I still have this problem.

    Anyone else?
     
  3. Littleodie914 macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #3
    I'm actually experiencing (what I think is) the same issue. When you say flickering, are you actually losing the connection entirely/blacking out the screen, or is it just weird garbage/distortion/shaking for a split second, then back to normal?
     

Share This Page