Macbook Pro 2011, Mac OSX Installation fails halfway (SSD)

Discussion in 'MacBook Pro' started by festgebaeck, Jun 3, 2018.

  1. festgebaeck macrumors newbie

    festgebaeck

    Joined:
    Jun 3, 2018
    Location:
    Germany
    #1
    Hi there,

    I want to reinstall OSX on my Macbook but the installation fails halfway with a "couldn't install/complete" error message.

    It started with performance hiccups and freezing and some other OSX problems after waking the machine from standby/sleep. I reckoned I must have either installed something that caused it or the System, which was updated all the way from Lion to Sierra, just gave in with all the bloat. It could very well be the RAM or SSD, but the SSD mounts ok when used externally.

    So far I tried:

    - Removing the SSD, formatting it externally with my other machine (Journaled), no errors
    - Verifying and repairing the disk with Disk Utility, with no errors.
    - Exchanging the RAM, with no change in the macs behaviour.
    - Using the Apple Hardware Test to determine whether something is wrong internally (no errors, even on extensive mode)
    - Used a bootable USB drive with Mavericks and El Capitan, trying to reinstall. But no luck so far, both fail with the same error.
    - Used Internet Recovery to install Lion, which also fails midway.
    - Checked the temperatures. Maybe the old CPU can't handle the installation stress. But temperatures are idling at around 50-60° Celsius. Not ideal, but not to worrying either.
    - Used Terminal to set the date of my machine to an appropriate day/year, to avoid any verifying errors regarding the Installers.

    Everything seems to be pointing at hardware failure. But the mac boots up as usual and I can navigate the installation process normally. Only after starting the installation, it either freezes or resolves in an error message.

    It could be the battery (an original from 2011)...

    Maybe someone here can point me in the right direction, although this might be irreversible. :(
    I uploaded an error log from trying to install Lion.

    Thanks for any tips!
     

    Attached Files:

  2. tubeexperience macrumors 68040

    Joined:
    Feb 17, 2016
  3. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    I would suggest you get one of these dongles:
    https://www.amazon.com/Sabrent-2-5-...478&sr=1-2-spell&keywords=sabremt+usb3+to+ssd

    The following test can use either the SSD from the MacBook (you'll have to take it OUT OF the MacBook, of course), or if you have the original platter-based hard drive you could try that as well).

    - You'll need to take the SSD out of the MacBook (leave the drive bay empty for now)
    - Put the back on (just use a few screws to hold it in place)
    - Connect the SSD to the USB3/SATA adapter dongle and connect it to the MacBook
    - Press the power on button
    - IMMEDIATELY hold down the option key and KEEP HOLDING IT DOWN until the startup manager appears.
    - Do you see the external drive "on the dongle"? If so, select it with the pointer and hit return.
    - Observe what happens. Do you get a good boot, or the same problems?

    If you get a good boot this way, it suggests that the internal SATA ribbon cable needs replacement.
    If you get the exact same problems as before, it could point to something wrong with the drive (hardware or software), or something wrong with hardware inside the MacBook.
     
  4. sbuntin macrumors regular

    sbuntin

    Joined:
    Aug 2, 2011
    Location:
    Portland OR
    #4
    Fishrrman's test only works if the SSD already has OSX installed - otherwise it will not show up as a bootable drive.
    However, you can still use Internet recovery to install OSX on the SSD while the SSD is connected via USB dongle/enclosure.

    As for which enclosure/dongle to use - I'm a big fan of the Cable Matters tool-free enclosure. Slide it open, pop in the drive, close it.

    https://www.amazon.com/gp/product/B00DLBTJ52/ref=oh_aui_search_detailpage?ie=UTF8&psc=1
     

Share This Page