Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

epicmanga

macrumors newbie
Original poster
Jan 25, 2014
2
0
Hi,

I wish I could show you pictures of my current situation but I am using Mac OS recovery help window.

I have SSD and HDD on my Mac (I removed CD-ROM). I tried installing windows on my computer via USB and using DiskUtility (I allocated some space for windows). Unfortunately, when I tried to delete everything and come back to my old one and only Mountain Lion I have a new problem. The current VolumeGroup has some free space partition that I cant do anything with it (tried erasing, partition, applying new changes. Nothing works). When I went to Terminal I got something like this:

GUID_partition_scheme 120.0 GB disk0 //my SSD
EFI 209.7MB disk0s1
Apple_CoreStorage 119.7GB disk0s2
Apple_Boot 134.2MB disk0s3

GUID_partition_scheme 320GB disk1 //my HDD
EFI 209.7MB disk1s1
Apple_CoreStorage 155.8GB disk1s2 //how come this one and disk3 are separated?
Apple_Boot 650MB disk1s3

then theres disk 2 with 1.3GB for MAX_OS_X Base System
and this weirdo:

Apple_HFS 269.6GB disk3

disk 3 should belong to disk 1. I have no idea why it got separated. I tried erasing it but it said it "Formatting is not supported by HFS hfs MAC OS Standard"

This is why in Disk Utility I see this:

VolGroup (275GB and its made of disk0s2 and disk1s2)
Macintosh HD (which is disk 3) 269GB.


My goal is to merge disk3 with disk1 so I can finally get back everything as it used to be and then make the fusion. Now I cant do anything. Seriously, where did the disk3 come from and why I cant get rid of it?

Help would be much appreciated.
 
Last edited:

Weaselboy

Moderator
Staff member
Jan 23, 2005
32,955
13,171
California
Run the command below in Terminal then post up the output. This will show the layout of your partitions plus the logical volumes created by Fusion, then I will try and help you sort it out.

Do you have everything backed up so we can completely blowout all the partitions to start over?

Code:
diskutil cs list
 

epicmanga

macrumors newbie
Original poster
Jan 25, 2014
2
0
Thanks for that. It helps to have a better look. So I have two volumes? The one main VolGroup. Whats the volume family?

Yes, everything is backed up. I cant wait to blow out everything here!

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group A06CCEC6-6590-40A7-8902-2A97C07D6AF1
=========================================================
Name: VolGroup
Status: Online
Size: 275524624384 B (275.5 GB)
Free Space: 0 B (0 B)
|
+-< Physical Volume 0001826F-B784-45F0-AB71-1679F1BB6B8E
| ----------------------------------------------------
| Index: 0
| Disk: disk1s2
| Status: Online
| Size: 155834474496 B (155.8 GB)
|
+-< Physical Volume 2C8206C7-79C2-48BF-9BFF-48C79128AE6D
| ----------------------------------------------------
| Index: 1
| Disk: disk0s2
| Status: Online
| Size: 119690149888 B (119.7 GB)
|
+-> Logical Volume Family 3BB5E8DA-700E-40B5-9FE6-EBFD7A69E976
----------------------------------------------------------
Encryption Status: Unlocked
Encryption Type: None
Conversion Status: NoConversion
Conversion Direction: -none-
Has Encrypted Extents: No
Fully Secure: No
Passphrase Required: No
|
+-> Logical Volume FF65EE30-6B86-4F0D-AFD0-4A8EA0AE1D2E
---------------------------------------------------
Disk: disk3
Status: Online
Size (Total): 269560053760 B (269.6 GB)
Size (Converted): -none-
Revertible: No
LV Name: Macintosh HD
Volume Name: Macintosh HD
Content Hint: Apple_HFS


So I got rid of CoreStorage. Now when I enter diskutil list this is what I get:

#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *120.0 GB disk0
1: EFI 209.7 MB disk0s1
2: Apple_HFS Untitled 119.7 GB disk0s2
/dev/disk1
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *320.1 GB disk1
1: EFI 209.7 MB disk1s1
2: Apple_HFS Untitled 155.8 GB disk1s2
3: Apple_Boot Boot OS X 650.0 MB disk1s3
/dev/disk2
#: TYPE NAME SIZE IDENTIFIER
0: Apple_partition_scheme *1.3 GB disk2
1: Apple_partition_map 30.7 KB disk2s1
2: Apple_HFS Mac OS X Base System 1.3 GB disk2s2
/dev/disk4
#: TYPE NAME SIZE IDENTIFIER
0: untitled *524.3 KB disk4

So my problem is that disk1s2 should be ~320GB, not half of it.




So I deleted the coreStorage, tried deleting partitions from terminal again (didnt work). Then I restored my old OS (which was still Lion), stick USB and installed RecoveryDiskAssistant. Restarted computer while holding ALT/OPTION. Clicked on the recovery USB and from there went to diskutility where I could partition whatever I wanted and I finally could see both my drives.

Thanks Wieselboy for telling me about diskutil cs list because that showed me that I can deal with volumes (even though later I saw that terminal also listed coreStorage as an option).

Case closed.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.